PfSense Dynamic DNS and Google Domains Dynamic DNS service



  • Hello all!
    New to the forums here, finally hit a problem on pfSense that has me stumped and no documentation. Google recently launched a free dynamic DNS service for those who are using their domains services.

    What I can't figure out is how to get pfSense to work with it.

    Here's Google's documentation (server config examples about half-way down the page): https://support.google.com/domains/answer/6147083?hl=en

    I've fiddled around with a few options, experimented and all that. The documentation for pfSense's dynamic DNS settings isn't very useful: https://doc.pfsense.org/index.php/Dynamic_DNS

    I did notice that things get really slow/unresponsive if pfSense's dynamic DNS settings are not good (took a minute to load the page after saving settings, another minute or two to delete the test) - I get the feeling that leaving things mis-configured could lead to a crash. It's running on a pretty solidly-specced machine and is normally zippy. This might be worthy of a patch to create a time-out or similar.

    Since Google Domains is still in beta and invite-only, it may be difficult to test/verify. If you would like to help me and try, I will make a temporary subdomain for the purpose of testing - please send me a message and I will reply with the temporary user/pass.



  • I would try the following under Services: Dynamic DNS clients.  No clue if it will work

    
    Service type: -> Custom
    Interface to monitor: -> WAN
    Interface to send update from: -> WAN
    User Name: -> anything 
    Password: -> anything
    Update URL: -> https://YOUR_USERNAME:YOUR_PASSWORD@domains.google.com/nic/update?hostname=YOUR_HOSTNAME&myip=%IP%
    

    Substitute the values in CAPS labeled "YOUR_XXXX" for your data.



  • Verified, It works! Thanks

    Joe



  • Awesome, thank you so much!



  • @switchman:

    I would try the following under Services: Dynamic DNS clients.  No clue if it will work

    Thanks

    This also works for setting a SmartDNS update with CactusVPN.


Log in to reply