Squid3 reverse proxy issues

  • Hey there, in pfsense 2.1.5 I've got a pretty simple setup (2 wans, 3 lans and a dmz) with a couple of web servers, and multiple websites, behind a pfsense virtual firewall (ESX) and squid3 set to work in reverse proxy mode. Everything's fine.

    Same setup on a 2.2 setup won't work. Neither does with the last squid3 release/package.
    Everytime I try to bind it to listen on port 80, I get an error message saying I need to lower net.inet.portrange.first from 1024 to 0, which I did at least 20 times ;D with no results, tried restarting squid-restarting the entire vm, no results.
    In the squid's log all I get is a permission denied when trying to bind on port 80.

    Is this a known issue?
    Thank you for all your hard work, everything but squid is running great on 2.2RC.


  • On your 2.2 setup, did you do an upgrade from 2.1.5 to the RC or was it a fresh install?

  • Fresh install, didn't try the NAT redirect setup yet, but when trying to bind everything above port 1024 doesn't seep to pop up errors.
    The strange thing is that the above mentioned system tunable seems to have no impact even if the reverse proxy clearly states that lowering the value to 0 should solve the problem.
    Thank you.

  • I take you rebooted after changing the system tunable value?

  • Thank you for your answer, yes I did. Looks like a bug tbh

  • I've tried setting the tunable value from the pfS web config AND in sysctl at the console, but it refuses to change.  This has got to be something weird with the base.

  • That's the problem then… :)

Log in to reply