Config file from 1.2.3 cannot be imported on 2.1.5



  • Greetings,

    I wanted to upgrade my Alix from a long-running 1.2.3 to the newest, both i386. So I exported the config file, no addons where installed, file was not encrypted.
    I flashed the proper image over the CF (1GB in my case), bootet, set the IP adresses via putty (serial), rebootet, everything was fine. But when I wanted to
    restore the config file, I got the following error:

    The following input errors were detected: The configuration could not be restored

    I found a couple of threads, but none brought up any good ideas. I tried to install a fresh 2.0.0 first, but without luck.
    I reflashed a 1.2.3 install, restored - works like a charme.

    Any advice from the pros?

    Regards
    Guybrush



  • Have you tried running an in-place upgrade instead of flashing the drive? If so, and if you have a virtual environment to hand such as vSphere, Xen, etc, you could try installing 1.2.3 on a VM, restoring the config to that device, upgrade it in-place and then re-export from there onto your live box.


  • Netgate Administrator

    The most common cause of this going from 1.2.X to 2.X if I recall was a restriction in the character set being used that meant the config file is seen as corrupt. See:
    https://doc.pfsense.org/index.php/Upgrade_Guide#International.2FSpecial_Characters_in_1.2.x_Configurations

    Steve


Log in to reply