Sync not working



  • Hi,
    I set up a pair of new pfsenses and want one of them to sync aliases, rules etc. to the second one.

    The sync-NICs are connected with a bridge cable, they can ping each other, IP are 192.168.0.1 and 192.168.0.2.

    Second FW has a rule at Sync for TCP/UDP Port 443, Destination: WAN-ADRESS

    User admin´s password is set at System: High Availability Sync of Master-FW and identic with admins pw at the Slave.

    But Master always give me "… Communication error occured while attempting XMLRPC sync with username admin https://192.168.2:443

    What is my mistake?

    Fred


  • LAYER 8 Netgate

    But Master always give me "… Communication error occured while attempting XMLRPC sync with username admin https://192.168.2:443

    Is this really the URL?

    192.168.2 is not a valid IP address.  You probably want 192.168.0.2.

    Check your settings in System > High Avail. Sync



  • Sorry: of course i forgot the "0" in my post.

    The two Sync-NICs own  192.168.0.1 and 192.168.0.2

    Best wishes
    Fred



  • @dark.fibre:

    The sync-NICs are connected with a bridge cable, they can ping each other, IP are 192.168.0.1 and 192.168.0.2.

    Second FW has a rule at Sync for TCP/UDP Port 443, Destination: WAN-ADRESS

    What is my mistake?

    If you have separated sync-NICs, why do you allow traffic to WAN address for syncing?

    Just add a rule on both boxes on sync interface to allow traffic from any to any and it will be done.
    The sync packets uses pfsync protocol, not TCP nor UDP!


Log in to reply