UPnP handling different to 2.1?



  • Hello Folks,

    at first I thought it is a general Problem with my settings and the pfsense. But after I'm digging deeper it might not the baddest idea that someone will overlock it.

    Xbox one - Nat is open
    PS4 - Nat is Type 2 (UPNP like in PS3 is not listed)

    I try to get through the ps3 network test…

    PS3 set via DHCP
    IP 192.168.2.XXX
    Sub 255.255.255.0
    Gate 192.168.2.1
    DNS 192.168.2.1

    IP Adress test - ok
    Internet test - ok
    PSN - ok
    UPnP - not available
    NAT-Type - Type 2
    Down - 20Mpbs
    UP - 1.9Mpbs

    I want that UPnP will be tested - ok. It worked with 2.1.3 then I skipped to 2.2 RC and know something must be different in the UPnP communication?!
    If I use something like a AVM "Fritzbox", the UPnP is fine. Just can't get back to 2.1.3 :(

    I go today to a friend who runs the 2.1.5 and will test it there with my NAT Settings. Any help or hint would be great!

    Screenshots of the actual settings are attached







  • So I'm now at my friends PFSense, we just upgraded from 2.1.5 to 2.2 RC and here is the UPnP working with the PS3.

    He has a rule in the NAT which I cant fill out in my one and in his after upgrading. Always get an error. Is this needed for a working UPnP?

    WAN  127.0.0.0/8 * * * WAN address 1024:65535 NO Auto created rule for localhost to WAN

    The Nat port range with 1024:65535 is not possible in 2.2 RC to fill in!

    Still no plan why it's working here and not at my home?!

    Any ideas or suggestions?








  • I have RC from 16th Jan running.

    Here is my relevant info to get upnp working.
    I've added upnp ports as aliases (2189 and 5351) to the FW rules and added also two rules for allowing multicast.
    I use the Hybrid mode for the Outbound NAT rules.

    The only issue I have is on "clear" (upnp status page) or Upnp restart.
    The system log (routing) states multiple times:

    "miniupnpd[41252]: sendto(udp_shutdown=-1): Bad file descriptor" 
    

    I've googled for this error but could only find old dated info regarding not allowing multicast on LAN, but I've already have those rules setup.

    So these log error are cosmetic as far as I'm concerned, because the consoles work fine with upnp and NAT is found as "type-2" or "open".












  • Thank you dir the help. I'm just now in my Holiday nur will Check it nett Werk and reply!


Log in to reply