What's the official 2.2 upgrade URL?



  • The autoupdater on my 2.2-RC installations only find the latest RC upgrades, dated 16th of January or something like that. When I reload the updater settings to "stable updates" and uncheck the "use unofficial server", things complain about unsigned images…

    ...I mean, I can update, if I leave the "use unofficial server" thing checked, but that's not really how things should be, because after all, official updates should come from an official server, right?





  • @kejianshi:

    http://updates.pfsense.org/_updaters/amd64

    For mine anyway…

    Well, yes, that's what I get, too, BUT: if you uncheck the "Use an UNofficial server for firmware upgrades" checkbox, then that URL goes blank, and upgrades won't happen.
    I shouldn't have that checkmark be active when I want official upgrades from a trusted source, right?

    Maybe just the legend to the check mark is wrong, and it should be "Use an official server…" instead of "Use an unofficial server.."???



  • I'm assuming that anything ending with pfsense.org is official and anything thing ending in anything else isn't.

    Perhaps a big assumption.  Not sure.



  • @kejianshi:

    I'm assuming that anything ending with pfsense.org is official and anything thing ending in anything else isn't.

    Perhaps a big assumption.  Not sure.

    Well, sure, that makes sense intuitively, but why does the pfSense GUI not get that?
    Hence my confusion, I should have to be able to have that thing unchecked and the upgrade still work, but that seems to be currently not possible.

    So maybe that's a bug; if anyone of the developers could confirm either way, that would be useful…



  • I'll add a redirect on snapshots at some point yet tonight so those pointing to snapshots for auto-update will get redirected to the stable updates URL.

    There is no update manifest on snapshots which is why there is no drop down there (right now at least) to pick the official URLs.



  • Not sure we're talking about exactly the same thing: I have now the official release installed, and yet:
    when I go to Firmware > Updater Settings, the "Use an unofficial server for firmware upgrades" is checked. If I uncheck it, the Base URL field goes blank. If I use the "Default Auto Update URLs" selector to select "pfSense amd64 stable updates (Current architecture)", then the Base URL field is populated again with "https://updates.pfsense.org/_updaters/amd64", and the "Use an unofficial server for firmware upgrades" check is back turned on. If I turn it off, the Base URL field goes blank again, and the circle repeats.

    In other words, it seems to be impossible to have a valid URL there without that checkmark being checked.



  • Redirects added to snapshots.pfsense.org to send 2.2 snapshot auto-updates to the appropriate stable update URL, they should all be showing 2.2-RELEASE as the available update now.

    @rcfa:

    In other words, it seems to be impossible to have a valid URL there without that checkmark being checked.

    That's because there isn't a manifest on snapshots (though with the redirects in place now, it should). When there is, the updater settings shows "Default Auto Update URLs" at the top with a drop down box to pick which official source you want to use. Since that didn't exist on snapshots, that wasn't shown which is what makes it unclear. Where you can fetch the official update URLs, it shows those in a drop down so you don't need to put in anything manually.



  • Hm, headscratch. I feel like we're talking a bit past each other.

    There are two issues: one was that the RC did't pick up the release version. That seems to be fixed now, although I can't test that, because I had already manually updated to the release version.

    The second one, which still remains is this:

    Step 1: I start with nothing

    Step 2: If I use the pop-up to select the default auto update URL, then that fills in the firmware auto update URL field AND also checks the "use an unofficial server for firmware upgrades" checkmark.

    Step 3: If I uncheck that, the base URL field goes blank, if I save in that state (pop-up still on the correct default location),

    Step 4: then after the save the page comes back with nothing selected in the pop-up, empty base URL field, so in essence we're back to Step 1

    Step 5: I repeat Step 2 and immediately save without repeating Step 3 resulting in

    Step 6: Auto-update pop-up is empty, Base URL field is properly populated, but again, the "use an unofficial server" thing is active.

    What I would expect is that (see expected picture)

    A) the pop-up stays in the position it was saved in

    B) that if I select an official update URL, the "use an unofficial server" thing never gets selected and remains unselected throughout the procedure

    In essence either

    i) the Default Auto Update URLs pop-up should have three choices and always show one of them:
      pfSense stable 386, pfSense stable amd64, and custom URL, AND unless custom URL is chosen the Base URL field is simply disabled, making the "use an unofficial server" thing superfluous, because a custom URL is always unofficial OR

    ii) the Default Auto Update URLs pop-up should have three choices and always show one of them:
      pfSense stable 386, pfSense stable amd64, and custom URL, AND the Base URL field always shows the active URL, and if the active URL is an official one, the "use an unofficial server" thing remains deselected.

    ![Step 1.png](/public/imported_attachments/1/Step 1.png)
    ![Step 1.png_thumb](/public/imported_attachments/1/Step 1.png_thumb)
    ![Step 2.png](/public/imported_attachments/1/Step 2.png)
    ![Step 2.png_thumb](/public/imported_attachments/1/Step 2.png_thumb)
    ![Step 3.png](/public/imported_attachments/1/Step 3.png)
    ![Step 3.png_thumb](/public/imported_attachments/1/Step 3.png_thumb)
    ![Step 4.png](/public/imported_attachments/1/Step 4.png)
    ![Step 4.png_thumb](/public/imported_attachments/1/Step 4.png_thumb)
    ![Step 5.png](/public/imported_attachments/1/Step 5.png)
    ![Step 5.png_thumb](/public/imported_attachments/1/Step 5.png_thumb)
    ![Step 6.png](/public/imported_attachments/1/Step 6.png)
    ![Step 6.png_thumb](/public/imported_attachments/1/Step 6.png_thumb)


  • Netgate Administrator

    I see how that isn't the expected behaviour from your point of view.  :-\  A box showing the current update URL would perhaps help there.
    That's the correct behaviour though, there's nothing wrong with your install.

    Steve


Log in to reply