Solved: Interrupt storm on Intel mainboard



  • I've tested Pfsense with different kinds of hardware, such as the newest Intel mainboards with G33- and P35-, 965-, 865- and 845- chipsets. My last test was with an Intel DG945GCPE (945G chipset, mATX). The two available PCI slots I filled with the Intel Pro 1000GT network cards. The rest was simple; video onboard, one SATA HDD and an IDE DVD-rom.

    When I use the most bottom PCI slot (em1 on this machine), I get an Interrupt storm on IRQ9 on starting up. When started, I get a watchdog timeout on em1. A new BIOS, changed network cards and disabling all kinds of things like audio, print port, parrallel port and even the IDE adapter. Also worked out a link about disabling ACPI. But nothing helps.

    Talked about it with an Intel guy. He told me that IRQ 9 is given away by the OS or firmware. The complete conversation (with other names of course) you'll find underneath.

    Does anyone know how to solve this problem?

    _I've got a machine with a 945GPCE mainbord, two Intel Pro 1000 GT Network cards, one SATA HDD and an IDE DVD-rom. When I use the bottom PCI-slot, I get an "Interrupt Storm" on IRQ9. This is not so much a problem with windows, but on Linux or FreeBSD this causes problems.

    My questions are: what other device uses IRQ9, how can I change the IRQ of the bottom PCI slot and how can I test this mainboard on hardware failures (what also can cause an interrupt storm)?

    Please wait while we find a representative to assist you…
    All agents are currently busy. Please stand by.
    You have been connected to Intel guy .
    Intel guy : Hello my name is Intel guy, I am reviewing your question, please hold.
    Me: Hi Intel guy, take your time; this is a difficult question (I think).
    Intel guy : Hi Mr Jacob.. I have checked with my senior.. regarding the irq, it cannot be changed. it is the os that controlled the irq based on the firmware that you have.
    Intel guy : for linux, we have no idea since we dont support linux, Sir
    Intel guy : regarding the network card, it does not support linux
    Me: Ok, clear. But how can I test this mainboard on failures that can cause an interrupt storm?
    Intel guy : there may be some third party parties software that may allow you to test for failure on irq, but Sir, we dont support third party software.
    Intel guy : it may be dos tools.
    Intel guy : and again linux we dont support it all, we cannot give advice on it
    Intel guy : windows it is a plug and play os which assigned the irq automatically
    Me: I know, but I'm thinking of a possible errr on the mainboard an how to test it. Doesn't Intel have any testing possibilities?
    Intel guy : i will check with that with my senior, please wait Sir.
    Me: Ok
    Intel guy : Thank you for holding Sir
    Intel guy : i have check with my senior.
    Me: No problem, I wait.
    Intel guy : http://en.wikipedia.org/wiki/Interrupt_request
    Intel guy : please check from this website. regarding x86
    Intel guy : it explains how to check for irq with linux command
    Me: Ok I'll study that first. Thanks Intel guy for your help!
    Intel guy : cat /proc/interrupts
    Intel guy : No problem Sir_



  • Have you tried the MP kernel on it? Loading RC2 on it? I keep asking this when people have interrupt issues, but it seems I am the only one to come across the problem where the RC3 UP kernel changes broke the PIC on the board I was using. I'm asking one more time, because the board I had trouble with was a micro-atx board with a 945GM and an ICH7M-DH controller, and the chipset may be close to your hardware.



  • I'm sorry that you had to ask again; I wasn't able to find anything on this subject. But that can easaly be my fault, so thanks for your help, Dotdash.

    What a concidence that you had almost the same board.

    I am not (yet) such an experienced user that I can follow you perfectly: What is the MP/UP Kernel? And Is RC… the revision of the version? I'm using the newest version, 1.2 (25th februari 2008).



  • The RC releases are Release Candidate builds used for testing new features, etc. before the final release comes out. The 1.2 RC's are not easily available anymore, so try a fresh install of 1.2 using the Live CD. Near the end of the install, it will ask what kernel you want to install- single/multi-processor, embedded, developer. Pick the multi-processor (SMP) kernel, and see if it changes anything. In my case, the SMP kernel was needed to make any of the nics function.



  • Ok. We'll do that. Strange if this works, since there's a celeron inside… The topmost PCI card and the LA online are working, by the way.



  • No I now why they call you a hero member and me a newby ;D

    The CPU a use is an Intel Celeron 440, so a single core. I used the Multi-processor (MP) modus on installation. It works perfectly!!!

    Thanks very much for your great help at this problem!!!!



  • No problem. It makes me feel slightly better about all the time I spent tracking the problem down to know someone else ran into the same thing. FWIW, I was using a Celeron-M 410 (Yonah)



  • So the SP (Single Processor) option at installation is not necessary? Or should be only for older CPU's?



  • It seems the Single Processor option works fine for most people. I haven't tested, but I'm guessing there is little or no performance penalty running the Multi-Processor kernel on a single core/processor system. There was a post by someone who was a hardware guy for Compaq that suggested the SMP kernel might give you better interrupt handling, but again, I haven't confirmed that either.



  • Well, as we can see in this case the Compaq guy could be right on this interrupt thing!


Locked