Havp not working after upgrade to 2.2 from 2.1.x



  • HAVP wont start as shown in dashboard or Services>Antivirus

    Get the following errors trying to run clamd or freshclam manually:

    freshclam

    freshclam: Command not found.

    clamd

    clamd: Command not found.

    find . -name clamd

    ./usr/local/etc/rc.d/clamd
    ./usr/local/sbin/clamd
    ./usr/pbi/havp-amd64/local/sbin/clamd

    /usr/pbi/havp-amd64/local/sbin/clamd

    Shared object "libclamav.so.6" not found, required by "clamd"

    #find . -name libclamav.so.6
    ./usr/pbi/havp-amd64/local/lib/libclamav.so.6

    ls -al /usr/pbi/havp-amd64/local/lib/libclamav.so.6

    lrwxr-xr-x  1 root  wheel  19 Dec  3 11:56 /usr/pbi/havp-amd64/local/lib/libclamav.so.6 -> libclamav.so.6.1.24

    ls -al /usr/pbi/havp-amd64/local/lib/libclamav.so.6.1.24

    -rwxr-xr-x  1 root  wheel  8960792 Dec  3 11:56 /usr/pbi/havp-amd64/local/lib/libclamav.so.6.1.24



  • same issue

    going to do a clean 2.2 install



  • Same for me.
    And it also seems to be related to the retired snapshot issue ( https://forum.pfsense.org/index.php?topic=86890.0 ) and with restoring the previous configuration from 2.1

    I miss all the files from c-icap:

    $ service c-icap onestart
    c-icap does not exist in /etc/rc.d or the local startup
    directories (/usr/local/etc/rc.d)

    ??



  • It will not start for me either.  I tried deleting and reinstalling.

    Full 64bit install on an ssd.

    Kevin



  • I think it is a squid problem though.



  • same here
    after upgrade from 2.1.5 to 2.2
    havp dont work



  • Hi,

    Is there any solution?
    I want to use havp on pfSense 2.2.


Log in to reply