Snort fails on 2.2



  • Hi!  I'm having a little problem with snort.  I upgraded to pfSense 2.2 thismorning and Snort wouldn't start.  I tried to manually start it, but that didn't work either.  Unfortunately, I don't know where the snort log files are.  My system log is here…

    http://pastebin.com/9Pd7JeKw

    I then tried to uninstall snort and reinstall it.  When reinstalling, I get the following error...

    ...
    Installation of snort FAILED!
    ...
    Beginning package installation for snort .
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading snort and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/snort-2.9.7.0-amd64.pbi ...  (extracting)
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Include snort.inc is missing!
    Removing package...
    Starting package deletion for snort-2.9.7.0-amd64...done.
    Removing snort components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file snort.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.
    ...

    I'm assuming that it has to do with the package maybe not being updated for pfsense 2.2.  Just checking in to see if anybody else has seen this or if it's a problem with the package.


  • Moderator

    It has something to do with this:

    Include snort.inc is missing!
    

    What hardware and version of 2.2 are you using? Are you out of hard drive space?

    Did you try a full de-install. (Ensure that "Keep settings after de-install is enabled"), then do a fresh install?



  • Thanks for the response.  I have 12% of my drive full of the 14gb available.  I'm also running it inside of a vmware esxi virtual environment.

    When I uninstalled it, I just hit the 'x' in the "Installed Packages" section.  Is there a purge available?


  • Moderator

    That is the correct method to remove the pkg… There is no other purge.. Unless if you had to manually rip something out from the shell by hand..

    Snort is quite large. It downloads the compressed files, and then needs to extract them.. But i dont know exactly how much space is required.

    Try a reboot and then re-install.



  • Yup, I just rebooted and reinstalled and it installed fine.  It also started snort fine too.

    Thanks!


Log in to reply