Random Crash



  • I've been having random crashes all day long.  I just submitted the crash report about 10 minutes ago.  Can someone help to figure out why it keeps crashing?  It only seems to crash once I start a rsync copy of an openvpn connection.  The instant the rsync copy starts, the pfsense server crashed.  I tried using different hardware (i.e. motherboard, cpu, network cards) but it has the same result.  I even tried upgrading to 2.2 which is where this crash report came from.  The rsync copy is being initiated from one of our NAS devices.  Any ideas on why starting an rsync copy would crash pfsense?  By the way, the rsync copies are of folders that have close to a million files under the directory and sub directories.

    Thanks for you help in advance.

    Mike



  • Is rsync running on PFSense or is it just rsync traffic going through PFSense?

    How is your network setup?

    What hardware does PFSense have?



  • It's just the rsync traffic that is going through pfsense that is causing the crash.

    The pfsense has two wan connections, 1 LAN, and 1 sync connection.  No VLAN are being used.

    The pfsense server currently has tyan motherboard with a Intel Core i5 and 16GB of RAM.  I also had the same problem on my other pfsense server running and Intel Atom processor and 2GB of RAM.



  • I just had another crash (which I submitted) from an rsync copy that was coming into the LAN from one of the WAN connections.  So it does not appear to just be related to an openvpn connection or an outgoing rsync connection.



  • maybe mbuf exaustion ?
    https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards

    check the rrd graphs to see if your running close to the limit (status –> rrd graphs --> system -->mbuf



  • Nope.  Not mbuf exhaustion.  I originally thought this might have been the issue but it's no where near the max.


Log in to reply