Services won't start after 2.1.5 -> 2.2 upgrade



  • I found a wonderful surprise today after swapping my firewall hardware.  I went from an old Dell 32bit tower and multiple nics to a Intel Nuc 64bit with vlans.

    2.2 IS AVAILABLE!!!  Unfortunately the update didn't go well.

    1. Fresh install of 2.1.5
    2. restore config backup from old hardware
    3. reconfigure interface settings to match new machine - System appears to be good.
    4. upgrade to 2.2
    5. reboot - booted fine
    6. network computers stop working as dhcp leases expire
    7. notice that dhcp service is not enabled on LAN, I did do this while new and old hardware was on the network at the same time
    8. reenable dhcp on settings page
    9. receive error "Fatal error: Call to undefined function pfSense_interface_getmtu() in /etc/inc/interfaces.inc on line 5116"
    10. this errors comes on up on many pages while saving/taking action

    Service status page all services are stopped, and the error shows while attempting to start them.

    Restore to full backup appears to not kick off.  Upload firmware package for manual update says not "The uploaded image file is not for this platform."

    Download Full backup page shows the file is 0 bytes, downloaded file is 85mb+

    Attempting to upload backup file to manual update page also shows "The uploaded image file is not for this platform."

    Help please!



  • Hmmmmmm…
    Not sure if its possible, but maybe do a full install of 2.2 and restore your old working config to that.



  • I haven't gone to the full reinstall yet.  As I was going to I spotted the "Upgrade from console" option.

    This didn't work as smooth as it should.  The reboot never happened.  I gave it a good 10 minutes or so.  This is a pretty fast system, it shouldn't take to long to extract an 86mb tgz file…

    So it forced the reboot after Ctrl-alt-del did nothing, and ^c dropped me to a # prompt where no commands worked.  ls finally gave me something, but it was something like "invalid EXEC format".

    So now all services start except ssh.  There is an issue with the key file missing, and apparently the auto generation isn't working.

    /etc/ssh/ssh_host_ecdsa_key
    /etc/ssh/ssh_host_ed25519_key

    Strange thing, I stated ssh from the console with "/etc/rc.d/sshd onestart" and I guess it generated keys, but didn't save them?  When I reran the command to get the paths for this post it reported sshd was already running, so I stopped it and tried to restart from the web and it failed as usual.  Restarting from console again tells me the files are missing. But restarts without generating new keys?



  • Update:  So I rebooted again and now ssh does auto start?

    Not sure if it fixed itself, or if running the commands below helped.  Found them in a post about ssh problems with the prerelease 2.2.  There was a quote from the script that I assume is part of the clean install process.

    https://forum.pfsense.org/index.php?topic=83333.msg456428#msg456428

    /usr/bin/ssh-keygen -t ecdsa -N '' -f /etc/ssh/ssh_host_ecdsa_key
    /usr/bin/ssh-keygen -t ed25519 -N '' -f /etc/ssh/ssh_host_ed25519_key

    So at this point I think am working.


Log in to reply