Mailscanner stopped working after upgrade



  • Heya,

    I did an upgrade from 2.1.5 to 2.2. After that whole Postfix/Mailscanner stuff stopped working.
    I decided to do a fresh setup of 2.2 in a VM and move config by config to it (Aliases, DHCP etc.).
    Created certs, FW rules etc. manually.
    All config settings for Postfix and Mailscanner I did copy from Web UI to Web UI. So these were a manual setup for these packages.
    Installed on the fresh install Squid 3, then Postfix and then Mailscanner.
    Squid and Postfix seem to be OK.
    Postfix just moaned about missing "/etc/aliases" which I copied from old system. But there it was aliases.db.
    But Mailscanner produces lot of error messages during setup and then never appears again anywhere in a log. Running mailscanner (–lint) produces no output. Just mailscanner = no output and also no log entry.

    Here is the output during setup:

    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: Successfully installed package: mailscanner.
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: The command '/usr/pbi/mailscanner-amd64/local/etc/rc.d/mailscanner start' returned exit code '1', the output was 'Starting mailscanner. /usr/pbi/mailscanner-amd64/local/etc/rc.d/mailscanner: WARNING: failed to start mailscanner'
    Jan 25 10:56:51	root: /usr/pbi/mailscanner-amd64/local/etc/rc.d/mailscanner: WARNING: failed to start mailscanner
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: Starting MailScanner
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: The command '/usr/pbi/mailscanner-amd64/bin/sa-update' returned exit code '255', the output was ''
    Jan 25 10:56:51	root: /usr/pbi/mailscanner-amd64/local/etc/rc.d/clamav-clamd: WARNING: failed precmd routine for clamav_clamd
    Jan 25 10:56:51	root: /usr/pbi/mailscanner-amd64/local/etc/rc.d/clamav-clamd: WARNING: /usr/local/etc/clamd.conf is not readable.
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: Mailscanner- No spamassassin rules found, forcing sa-update.
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: The command '/usr/pbi/mailscanner-amd64/local/etc/rc.d/dccifd start' returned exit code '1', the output was '/usr/pbi/mailscanner-amd64/local/etc/rc.d/dccifd: WARNING: /usr/local/dcc/libexec is not a directory.'
    Jan 25 10:56:51	root: /usr/pbi/mailscanner-amd64/local/etc/rc.d/dccifd: WARNING: /usr/local/dcc/libexec is not a directory.
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: Starting dccifd
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: Starting clamav-clamd daemon
    Jan 25 10:56:51	check_reload_status: Syncing firewall
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: The command '/usr/pbi/mailscanner-amd64/local/etc/rc.d/mailscanner start' returned exit code '1', the output was 'Starting mailscanner. /usr/pbi/mailscanner-amd64/local/etc/rc.d/mailscanner: WARNING: failed to start mailscanner'
    Jan 25 10:56:51	root: /usr/pbi/mailscanner-amd64/local/etc/rc.d/mailscanner: WARNING: failed to start mailscanner
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: Starting MailScanner
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: The command '/usr/pbi/mailscanner-amd64/bin/sa-update' returned exit code '255', the output was ''
    Jan 25 10:56:51	root: /usr/pbi/mailscanner-amd64/local/etc/rc.d/clamav-clamd: WARNING: failed precmd routine for clamav_clamd
    Jan 25 10:56:51	root: /usr/pbi/mailscanner-amd64/local/etc/rc.d/clamav-clamd: WARNING: /usr/local/etc/clamd.conf is not readable.
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: Mailscanner- No spamassassin rules found, forcing sa-update.
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: The command '/usr/pbi/mailscanner-amd64/local/etc/rc.d/dccifd start' returned exit code '1', the output was '/usr/pbi/mailscanner-amd64/local/etc/rc.d/dccifd: WARNING: /usr/local/dcc/libexec is not a directory.'
    Jan 25 10:56:51	root: /usr/pbi/mailscanner-amd64/local/etc/rc.d/dccifd: WARNING: /usr/local/dcc/libexec is not a directory.
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: Starting dccifd
    Jan 25 10:56:51	php-fpm[18444]: /pkg_mgr_install.php: Starting clamav-clamd daemon
    Jan 25 10:56:51	check_reload_status: Syncing firewall
    Jan 25 10:54:26	check_reload_status: Syncing firewall
    Jan 25 10:54:25	php-fpm[18444]: /pkg_mgr_install.php: Beginning package installation for mailscanner .
    

    Whatever I try, there are no more log entries about mailscanner. Even starting on GUI produces "nothing".
    Running freshclam works fine. sa-update = no output.

    The "missing" clamd.conf I copied from old system also, as it was really missing.
    After first install the folder /usr/local/dcc" was missing, I simply created it, but see now, more is missing with this…

    Possibly some things are missing in the package?

    Any idea?

    Thanks!

    Holger



  • Hum… just realized the log of Postfix looks on both systems bad:

    Jan 25 11:29:37 pfsense postfix/master[37307]: warning: process /usr/local/libexec/postfix/pickup pid 68124 exit status 1
    Jan 25 11:29:37 pfsense postfix/master[37307]: warning: /usr/local/libexec/postfix/pickup: bad command startup -- throttling
    Jan 25 11:29:37 pfsense postfix/master[37307]: warning: process /usr/local/libexec/postfix/qmgr pid 68239 exit status 1
    Jan 25 11:29:37 pfsense postfix/master[37307]: warning: /usr/local/libexec/postfix/qmgr: bad command startup -- throttling
    Jan 25 11:29:38 pfsense postfix/master[37307]: warning: process /usr/local/libexec/postfix/postscreen pid 68432 exit status 1
    Jan 25 11:29:38 pfsense postfix/master[37307]: warning: /usr/local/libexec/postfix/postscreen: bad command startup -- throttling
    
    

    So it looks, even if the service looks like it is up and running, no mail is processed. I did disable third party antispam, but is is the same…



  • Until I find a way to workaround these pbi issues,  keep postfix and mailscanner on 2.1



  • Is there a ticket to track this issue at all?

    As above, same issue. I originally had an issue with clam, which was resolved by typing 'freshclam' in shell.

    However, I can confirm that mailscanner doesn't work on 2.2 RELEASE.



  • A tracking issue has been created:

    https://redmine.pfsense.org/issues/4508


Log in to reply