Traffic graph on dashboard not working

  • Since my update to 2.2 the traffic graph on the dashboard stopped working.
    Anyone else have this problem?
    Any idea on how to fix it?

  • mine has never worked well with chrome for some reason, but its fine on other browsers.

    Tried removing and readding ?

  • I use Firefox but I will try that and report back. I even reloaded the system and restored the config, no change

  • Did you try closing FireFox completely?

  • yep, just got back. Restarted my desktop, tried again and tried in IE, no such luck. I have given up for now. WAY to many bugs in 2.2, rolled back to 2.1.5

  • works for me, v2.2 and chrome(book).

  • I just recently ready about a stale cache issue. Apparently it is necessary to clean the internet history and delete all temporary internet files to get it to work correctly. I haven't tested this but if it's working for you guys I'm betting that is the case.
    Thanks for replying back guys.
    I think for the time being I'll wait to upgrade to 2.2 and wait for the rest of the bugs to get worked out.

  • Hi,

    Before to start : Sorry for my english …

    I'm also affected by this issues.

    I tried to clean the internet history and delete all temporary internet files first, but without result.

    The Traffic Graph works if you invoke it with the correct URL, but not in the page "Traffic Graph" and the dashboard :

    How to invoke it :

    https://[your pfSense IP or URL]/graph.php?ifnum=wan


    https://[your pfSense IP or URL]/graph.php?ifnum=lan


    https://[your pfSense IP or URL]/graph.php?ifnum=opt1


    https://[your pfSense IP or URL]/graph.php?ifnum=optX

    I found a miss option in the object tag of the HTML code of the page ">status >Traffic Graph" :

    With a pfSense 2.1.4, you can find this tag :

     <object data="graph.php?ifnum=wan" type="image/svg+xml" height="200" width="100%">[...]</object> 

    With a pfSense 2.2.2, you can find this one :

     <object data="graph.php?ifnum=wan">[...]</object> 

    With no other option and the Traffic Graph not work.

    But if you modify (with the Firefox developers tools) this tag and you add the option type="image/svg+xml",
    the Traffic Graph works perfectly :

     <object data="graph.php?ifnum=wan" type="image/svg+xml">[...]</object> 

    To workaround this issue in the Traffic Graph web page, you can replace the line #239 of the file /usr/local/www/status_graph.php :

     <object data="graph.php?ifnum=<?=htmlspecialchars($curif);?>&amp;ifname=<?=rawurlencode($ifdescrs[htmlspecialchars($curif)]);?>">with this line :

    <object data="graph.php?ifnum=<?=htmlspecialchars($curif);?>&ifname=<?=rawurlencode($ifdescrs[htmlspecialchars($curif)]);?>" type="image/svg+xml">The diff output :

    <         <object data="graph.php?ifnum=<?=htmlspecialchars($curif);?>&amp;ifname=<?=rawurlencode($ifdescrs[htmlspecialchars($curif)]);?>">
    >         <object data="graph.php?ifnum=<?=htmlspecialchars($curif);?>&amp;ifname=<?=rawurlencode($ifdescrs[htmlspecialchars($curif)]);?>" type="image/svg+xml">
    To workaround this issue in the dashboard, you can replace the line #176 of the file _/usr/local/www/widgets/widgets/traffic_graphs.widget.php_ :

    <object data="graph.php?ifnum=<?=$ifname;?>&ifname=<?=rawurlencode($ifdescr);?>&timeint=<?=$refreshinterval;?>&initdelay=<?=$graphcounter * 2;?> height=" 100%"="" width="100%">With this line :

     <object data="graph.php?ifnum=<?=$ifname;?>&amp;ifname=<?=rawurlencode($ifdescr);?>&amp;timeint=<?=$refreshinterval;?>&amp;initdelay=<?=$graphcounter * 2;?> " type="image/svg+xml" height="100%" width="100%">The diff output :

    < <object data="graph.php?ifnum=<?=$ifname;?>&ifname=<?=rawurlencode($ifdescr);?>&timeint=<?=$refreshinterval;?>&initdelay=<?=$graphcounter * 2;?> height=" 100%"="" width="100%">---

      		 <object data="graph.php?ifnum=<?=$ifname;?>&amp;ifname=<?=rawurlencode($ifdescr);?>&amp;timeint=<?=$refreshinterval;?>&amp;initdelay=<?=$graphcounter * 2;?> " type="image/svg+xml" height="100%" width="100%">I don't report the bug yet,

    but if someone can confirm the issue and report it.

    My configuration :
    pfSense 2.1.4 :
    Hardware : FW7541 version D
    CPU : Intel(R) Atom(TM) CPU D525 @ 1.80GHz
    RAM : 4Go
    Wan : 2
    Lan : 3

    pfSense 2.2.2 :
    Hardware : qemu-kvm 1.1.2 on debian7
    CPU : QEMU Virtual CPU version 1.1.2
    RAM : 512 Mo
    Wan : 1
    Lan : 1

    Firefox : 37.0.2
    OS : Mint 17 (based on ubuntu)

    Best Regards,</object></object>


  • maxty advice worked perfect for me. To show the line numbers in VI is

    :set number

    totally fixed this issue i have had for many many releases!

  • maxty's advice also worked for me. Pfsense version was 2.2.4 and line number on traffic_graphs.widget.php was now 181 instead of 176.

  • Banned

    Much easier fix: - merged and will be fixed in next 2.2.5 snapshot.