Swap Not Enabled on Boot



  • cat /etc/fstab
    # Device                Mountpoint      FStype  Options         Dump    Pass#
    /dev/ada0s1a            /               ufs     rw              1       1
    /dev/ada0s1b            none            swap    sw              0       0
    
    

    fstab has it. System isn't loading it. Was there on clean install, gone after backup restore?

    "swapon /dev/ada0s1b" and swap is back.

    How can I make this load at boot?


  • Rebel Alliance Developer Netgate

    If you reboot, does "swapon -a" also start it up?



  • Sorry for taking so long to reply.

    @jimp:

    If you reboot, does "swapon -a" also start it up?

    Yes.

    Rebooted. No swap.

    swapon -a
    swapon: adding /dev/ada0s1b as swap device
    
    


  • You have 4GB of ram. Do you really need swap?



  • No, not really. But that's not the issue.


  • Rebel Alliance Developer Netgate

    What is in /etc/platform on that box?

    Unless somehow it's set to something it shouldn't be (cdrom, nanobsd, jail) then it should be running swapon -a during boot, and if it works from the command line it should work from there.



  • cat /etc/platform
    pfSense


  • Rebel Alliance Developer Netgate

    Hmm, that's right as well. I don't see how it's not activating at boot time for you. There isn't anything to turn that off and all indications are that it should be on and running.



  • I'm having the same issue on pfSense 2.3.2p1 amd64.

    I have 8 GB of RAM but for some reason the amount of "inactive" memory on my setup is really high.  The only package I have installed is squid.

    I average about 30-40M of "free" memory which upon moments of additional load on my systems completely maxes out and causes kernel panics/reboots/lockups.

    Disabling squid gets me about 200M more of free memory and these kernel panics do not happen.

    Activating swap manually with swapon /dev/… works and allows some breathing room and no more kernel panics even with squid enabled.

    I read that this inactive memory is another type of caching that gets flushed when memory is needed.  However, with my system this doesn't seem to get flushed fast enough.

    Does anyone know how to "force" lower the amount of inactive memory allocated?


  • Rebel Alliance Developer Netgate

    That is not the same issue. Start a new thread rather than reviving a nearly two-year-old thread that isn't related.


Log in to reply