Erro após upgrade de 2.1.5 para 2.2



  • Boa Tarde,

    Efetuei o upgrade da versão 2.1.5 para a versão 2.2.

    Depois de reboot começou a aparecer o erro:

    Fatal error: call to undefined function xml_parse_create() in /etc/inc/xnlparse.inc line 177

    Na consola assim que escolho alguma opção aparece o erro acima. Apenas funciona a Shell, pfTop e o Filter Logs.
    Não configura as interfaces, nem corre o webconfigurator.

    Alguém me pode dar uma dica de como sair desta?

    Obrigado.



  • No fórum internacional tem alguns reports de erros na migração.

    O pessoal esta contornando fazendo uma instalação limpa  e importando o backup do xml.



  • @marcelloc:

    No fórum internacional tem alguns reports de erros na migração.

    O pessoal esta contornando fazendo uma instalação limpa  e importando o backup do xml.

    Agradeço a dica. E foi o que fiz.
    Mas agora com uma instalação limpa o php-fpm não está a correr e no browser ao tentar aceder ao webconfigurator, retorna erro 503.

    Quando faço o restart do PHP-FPM na consola dá erro:

    Não acha o PID do processo pois ele não está a correr
    ERROR [pool light] cannot get gid for group 'wheel'
    ERROR FPM initialization failure

    Começo a ficar arrependido de ter feito o upgrade de 2.1.5 para 2.2.0. Esta versão não deveria ser ainda final.

    Alguma dica para resolver o problema do FPM-PHP?

    Obrigado.



  • Esse erro eu nunca peguei.

    Já tentou importar parte do backup de cada vez no lugar de importar tudo?



  • Eu ainda não fiz qualquer reposição de backup.

    Nunca tive acesso ao Webconfigurator, logo desde o primeiro reboot.

    Se calhar vou reinstalar novamente tudo de novo.

    Isto está dificil.



  • Após duas tentativas lá ficou a funcionar.

    Na primeira instalação limpa, tentei recuperar um backup na totalidade e ao arranque bloqueava no Firewall.
    Na segunda, apenas carreguei do backup os dados do openvpn e lá ficou a funcionar, e depois lá tive que carregar tudo novamente à mão.

    Julgo que ainda não é seguro ou pelo menos pratico passar do 2.1.5 para o 2.2.

    Será que eles vão corrigir esta situação?
    Tenho outra maquina para passar, mas não me apetece voltar ao mesmo problema. Vou esperar para ver.



  • Não tenho idéia.

    Essa semana vou começar  a simular os upgrades mas de antemão já sei que o melhor processo de atualização é  removendo os pacotes antes do update.




Log in to reply