From 2.1.5 to 2.2 - Supermicro, SSD, Insane reboot, crash - Bsdlabel invalid



  • Hi

    Did spend most of the day in DC, what a failure i had…

    I was going to upgrade 2 installations, 1 Supermicro box and 1 virtual (VMware)

    My setup was running CARP, so i started to upgrade the virtual according to upgrade guide. The virtual seems to get upgraded with no issues. Carp still running even with 2 different version, tried failover...  working!. Nice.

    Now to the box... The upgrade process went fine, and then reboot... Everything was looking great, i then tried to apply a limiter since it wasn't working in my previous setup...
    Suddenly... A bunch of commands and text rolled down the screen and the box crashed and rebooted. Secondary took over.
    As soon as box came online again, and the carp switched over to master, it started to crash again... Just going in loop now.

    I tried to install fresh 2.2 via usb, but then it wont install. Bsdlabel invalid, adas01 auto bla bla. So many errors. The disk were SSD disks in raid. But it could not see the virtual disk. Tried all different guides and tips. nothing worked.
    Went back to 2.1.5 installation usb and reinstalled, disk now available... installed and then updated trough interface (2.2)... and rebooted... same issue. it crashed and was going in loop.... now i am back at 2.1.5, the VM is reverted to 2.1.5 as well.

    Everything is working - also the limiter after reinstalling :-) - i will wait with 2.2 untill other come with better solutions. It is too early at this stage.



  • Bsdlabel invalid, adas01

    Is this the part where you have a raid but your system shows visible the raid and the disks that comprise the raid?  Seems someone already figured this out.  I know I've seen that in the last couple days posted.



  • That was one of the error. The installation never saw see the virtual drive (raid1) but was instead showing the 2 physical disks as non-raid. And if you tried to install it on disk 1 or 2 - both failed immediately when tried to install. But a workaround for me was to install 2.1.5 and then update trough gui. The critical part was not installation but rather the reboot/crash which results in loop.



  • Yep - Seems like someone may have already solved this.  I know 100% for sure its been talked about already.

    Clearly, installing on one of the disks comprising the raid isn't the answer.

    Can you edit your title to include "Bsdlabel invalid" so that you will attract an immediate related and correct reply?



  • Seems weird to me that hardware would show anything other than raid1 to the OS. 
    I will be watching.  I have no supermicro equipment here on hand, so I think changing the title is about all I can help with.

    That or dumping the raid (-;



  • Thanks a lot. Atleast there may be a workaround to the bsdlabel error.  :)
    What I also realized was the raid controller, if you chose the LSI software raid, it still wont appear. I was running Intel hardware raid anyway, but tried to toggle between several settings, and as you mentioned, dumping the raid should also work  :D



  • Some casual reading - Not sure if this will work.  Haven't tried it.

    https://doc.pfsense.org/index.php/Boot_Troubleshooting

    Boot Blocks/Loader Issues

    If a read error occurs during boot, please see this Boot Error.
        If FreeBSD will boot but not pfSense, try booting from a FreeBSD Live CD and running the following (More Info):

    fdisk -B -b /boot/boot0 /dev/ad0

    bsdlabel -B /dev/ad0s1

    (note that ad0 is the first ata hard drive)

    (so I'm guess where they have ad0, you need to identify which one is your raid and use that.)  I'm admitadly reading and guessing here.  No way to try it myself.
    (Might not apply to you I guess if you can't even see the RAID  )-:


  • Banned

    @kejianshi:

    Seems weird to me that hardware would show anything other than raid1 to the OS.

    There are also "HW" RAID controllers that present both individual drives and the RAID to the OS. Junk.

    Ditch the pointless "HW" RAID. If you want to RAID, use the software RAID included in FreeBSD.



  • Probably a really good suggestion.  I wouldn't be the one to configure something like that in BSD without doing some reading first.
    Got a link for how to do something like that so the OP can read it?


  • Banned

    The installer has an option to create and install to a RAID mirror. In 2.2, you even have a GUI to manage the RAID (forget dead drives and replace them…), widget and notifications.

    https://doc.pfsense.org/index.php/Create_a_Software_RAID1_(gmirror)



  • That is a cool option to have!

    "Starting with pfSense 2.2, e-mail alerts will be sent if the status of an array changes."

    I like it.


  • Netgate Administrator



  • Yes - Thats exactly what I was remembering.

    But I like doctornotors suggestion also.  Seems like this guy was using a hardware raid and thats cool, but software may also work great.

    I am not running raid on mine, so I can't say but I'm waiting to see if OP can make it work.


  • Netgate Administrator

    It seem more like an uncool 'hardware' raid!  :P Why expose the discs and the array to the OS?

    You mean disable the raid controller and use a GEOM mirror instead? I agree and Chris suggests that. His initial suggestion seems to be just to allow the box to boot.

    Steve



  • Yes - I also like the idea that pfsense will email me if I have a dead disk - Assuming I ran raid.
    I expect my particular SSD will outlast the foundation of my house…  Its slow and reliable.
    Its far my likely I'd eventually get tired of it than it would fail.
    BUT - This thread has me thinking that running a raid of very fast MLC drives might make good sense using GEOM for future builds.
    Long as I can easily know when my flakey SSDs need replacing.



  • Adding info to this thread:
    Regarding the limiter and kernel crash = reboot - Here is the bug report: https://redmine.pfsense.org/issues/4310
    It appears to happen only when running CARP.



  • @lowprofile:

    Adding info to this thread:
    Regarding the limiter and kernel crash = reboot - Here is the bug report: https://redmine.pfsense.org/issues/4310
    It appears to happen only when running CARP.

    Seems like there is a patch ready now? or am i wrong? Can we use "pfSsh.php playback gitsync RELENG_2_2" to apply the patch ?


  • Netgate Administrator

    You can gitsync to bring in everything or apply single patches using the System Patches package.
    If the fix is a single patch I would try just that first. If you gitsync you may pull in something undesireable.  ;)
    Both those options are unsupported etc….

    Steve



  • I couldn't find anywhere else to get an answer to this, but you are doing what I'm curious to try. I would like to know if two Intel SSD's (the support TRIM) are able to be used in the softraid 1 (The option the pfsense installer gives) with TRIM enabled? It seems as though TRIM gives them longer life, and RAID firther extends system uptime. I wouldn't want to throw dual SSD's in a system only to find that TRIM can't be enabled and they would have shorter lifespans that a single one!

    Thanks for any heads up or help you guys can give.


Log in to reply