NAT Squid 3.0 Issue ?



  • Hello Community,

    after a buisy weekend I discovered that there was an update to the pfSense firewall.
    So I decided to click it … I guess that was the worst decission ever ... might have worked on a Tuesday, but never do that Mondays.
    Anyhow.

    The setup:

    • Squid 3.x as transpartent proxy , using the standart port on the LAN interface.
    • LAN is clicked on the transpartent setting part
    • Lan is also activated for general interfaces ( top part)
    • no additional ACLs added
    • no additional settings

    The result :
    Squid stopped working after 2 minutes. So I was trying to investigate what caused that mess.

    What I did so far :

    • reinstalled squid ( same result , no internet access)
    • upgraded squid from version 2 to version 3, no change
    • downgraded to the prior version of pfsense ( very bad idea, cost my 2 hours of me life to fix it afterwards and re-roll to 2.2)
    • checked all log files. No result, nothing there that shouldn't be there

    What I found out:

    • When you access squid on the designated server port (3125)  - it works.
    • When I take the settings of my browser off ( direct internet access ) - no connection

    My question :

    • Does Squid set up a NAT rules for the server ? If so, would I see that on the NAT GUI ?

    I hope the section I opened the thread is the correct one, wasnt qutie sure where to put it.

    Thank you very much for any idea how I can fix this issue in advance.

    Best Regards
    Andi


Log in to reply