2.2 Fresh Install Issues on Watchguard Firebox x1250e and x5500e

  • Tried to upgrade my Firebox x1250e and x5500e twice and now I cant even get a console read out to see what is happening so I installed 2.2 fresh on a new HDD, btw the install from the CD was the slowest load and stalled at 30% during the install then just a finish screen. Sorry I cant get anything from the upgrades to fix that, on the new install I get this while watching it boot via console:

    Fatal trap 12: page fault while in kernel mode
    cpuid = 0; apic id = 00
    fault virtual address  = 0x0
    fault code              = supervisor read, page not present
    instruction pointer    = 0x20:0xc0da8cf0
    stack pointer          = 0x28:0xc2420c28
    frame pointer          = 0x28:0xc2420c34
    code segment            = base 0x0, limit 0xfffff, type 0x1b
                            = DPL 0, pres 1, def32 1, gran 1
    processor eflags        = interrupt enabled, resume, IOPL = 0
    current process        = 0 (swapper)
    [ thread pid 0 tid 100000 ]
    Stopped at      strncmp+0x20:  movzbl  0(%esi),%ebx
    <db>never ran into this before, ? does nothing, help shows a list of commands, since I have not had this before not sure where to go from here. Thought I was getting a mount issue, but guess not from the first part of the above stating "Fatal trap 12: page fault while in kernel mode". Checked the MD5 of the ISO files I downloaded and the MD5 hash matches the one provided on the download page.</db>

  • I have the same issue on X750e, does anyone found a solution for this error?

  • someone got it working by flashing the bios : https://forum.pfsense.org/index.php?topic=85930.msg479775#msg479775

  • updated subject to help others with the same hardware find the thread.


    someone got it working by flashing the bios : https://forum.pfsense.org/index.php?topic=85930.msg479775#msg479775

    Appears that's the same issue, but I think disabling DMA is what actually got it past that point. DMA is on by default for nano images now, which is best for nearly all hardware, but some like the Fireboxes still can't have DMA enabled. See the post right after that one for which settings to change.

    If you have one of these Watchguards and haven't upgraded yet, disable DMA in loader.conf.local before upgrading, and it'll work fine post-upgrade.

  • Netgate Administrator

    I'm going to put a HD back in my test box to play with this. I have a hard time believing the BIOS update could fully explain this. If it boots at all then the BIOS part is finished and working. The hard drive connector is definitely DMA capable and can be run as such:
    Note that since that is booting from cf it's running Nano and hence no swap. This seems to be swap related.

    Do any of you have a CF card in the slot?

    Perhaps more importantly did any of you run the ufslabels.sh script before upgrading?


  • Netgate Administrator

    Ok, so I pulled out my 20GB drive and blew the dust off it. Took a few tries to get it to boot, had to to use LBA mode in the BIOS. It was still loaded with 2.0.1! I ran the update straigh to 2.2 and it just went through with no problems. At one stage it complained of 'running out of file descriptors' which didn't look promising but it booted right up.
    The drive is incredibly slow. Like so slow it can't be running correctly.
    I'll pull out some other drive and try a fresh install tomorrow.


  • Netgate Administrator

    So I have now tried, with the same drive, a fresh 2.2 install. Again it went through with no issues and it's MUCH faster. Still have to set the BIOS to LBA mode though otherwise I get this:

    ada0 at ata0 bus 0 scbus0 target 0 lun 0
    ada0: <toshiba mk2018gap="" m1.42="" a="">ATA-5 device
    ada0: Serial Number 32K60131T
    ada0: 100.000MB/s transfers (UDMA5, PIO 8192bytes)
    ada0: 0MB (0 512 byte sectors: 16H 63S/T 16383C)</toshiba> 

    and then this:

    Trying to mount root from ufs:/dev/ada0s1a [rw]...
    mountroot: waiting for device /dev/ada0s1a ...
    Mounting from ufs:/dev/ada0s1a failed with error 19.

    What BIOS are you running? What BIOS settings are you running? Specifically:
    In Standard CMOS Settings, what access mode are you using for the HD? Is is set as Master/Slave/Auto

    In Intergrated Peripherals, IDE Controller, do you have DMA/UDMA enabled on all channels?

    If I can find one I'll try a larger drive, everyone with failures seems to be using 60 or 80GB.


  • Netgate Administrator

    Ok I've now replicated this. The issue is a BIOS setting. The critical setting is that ACPI must be enabled in the Power Management Setup menu. It isn't if you've loaded the default values. If you've upgraded from an earlier bios without clearing the CMOS then it might be, hence the confusion. Nothing else seems to prevent it booting though you probably also want to enable DMA/UDMA in the Integrated Peripherals, On-board IDE menu.
    Edit: The actual cause of this appears to be a regression in the gpioapu driver. https://redmine.pfsense.org/issues/4363. By enabling ACPI you are providing a value of some sort for smbios.system.product (even if that value is 0) and working around it.

    So you must set this:

                         Phoenix - AwardBIOS CMOS Setup Utility
                                Power Management Setup
    |    ACPI Function             [Enabled]              |        Item Help       |
    |    Power Management          [Disabled]             |------------------------|
    |    Video Off Method          [Blank Screen]         | Menu Level   *         |
    |    Video Off In Suspend      [No]                   |                        |
    |    Suspend Type              [Stop Grant]           |                        |
    |    MODEM Use IRQ             [3]                    |                        |
    |    Suspend Mode               Disabled              |                        |
    |    HDD Power Down             Disabled              |                        |
    |    Soft-Off by PWR-BTTN      [Instant-Off]          |                        |
    |    CPU THRM-Throttling       [75.0%]                |                        |
    |    Wake-Up by PCI card       [Disabled]             |                        |
    |                                                     |                        |
    |    ** Reload Global Timer Events **                 |                        |
    |    Primary IDE 0             [Disabled]             |                        |
    |    Primary IDE 1             [Disabled]             |                        |
    |    Secondary IDE 0           [Disabled]             |                        |
    |    Secondary IDE 1           [Disabled]             |                        |
    |    FDD,COM,LPT Port          [Disabled]             |                        |
    |    PCI PIRQ[A-D]#            [Disabled]             |                        |
      ^V><:Move  Enter:Select  +/-/PU/PD:Value  F10:Save  ESC:Exit  F1:General Help
         F5: Previous Values    F6: Fail-Safe Defaults    F7: Optimized Defaults

    You probably want this:
    Edit: Although some basic testing showed almost no improvement in drive speed.  :-\

                         Phoenix - AwardBIOS CMOS Setup Utility
                                   OnChip IDE Device
    |    IDE HDD Block Mode        [Enabled]              |        Item Help       |
    |    IDE DMA transfer access   [Enabled]              |------------------------|
    |    On-Chip Primary   PCI IDE [Enabled]              | Menu Level   **        |
    |    IDE Primary Master PIO    [Auto]                 |                        |
    |    IDE Primary Slave  PIO    [Auto]                 |                        |
    |    IDE Primary Master UDMA   [Auto]                 |                        |
    |    IDE Primary Slave  UDMA   [Auto]                 |                        |
    |                                                     |                        |
    |    *** On-Chip Serial ATA Setting ***               |                        |
    |    On-Chip Serial ATA        [Disabled]             |                        |
    |  x PATA IDE Mode              Secondary             |                        |
    |    SATA Port                  P0,P2 is Primary      |                        |
    |                                                     |                        |
    |                                                     |                        |
    |                                                     |                        |
    |                                                     |                        |
    |                                                     |                        |
    |                                                     |                        |
    |                                                     |                        |
      ^V><:Move  Enter:Select  +/-/PU/PD:Value  F10:Save  ESC:Exit  F1:General Help
         F5: Previous Values    F6: Fail-Safe Defaults    F7: Optimized Defaults


Log in to reply