Pfsense 2.2 one WAN two LANs IPv6 [SOLVED]



  • Hello,

    I was attempting to set up IPv6 from my WAN to a LAN and a DMZ. I get a /64 allocation from my ISP (TIme Warner/Roadrunner west). However, no matter what I do, in the LAN track interfaces I only get the 0 prefix ID, and my DMZ cannot use track interface as well (because it would use the same prefix ID).

    Right now I just have the default WAN settings of do not get a prefix. I have tried getting the prefix but that does not seem to help.

    I have a feeling I am missing something simple, but I am not sure what it is. Would anyone know what that would be?

    Thank you in advance!


  • Banned

    You cannot use a single /64 for two LANs.



  • This works for TWC footprint in NYC/HV area.

    WAN
    General:
    IPv6 Configuration Type  DHCP6

    DHCP6 client configuration:
    DHCPv6 Prefix Delegation size /56
    Send IPv6 prefix hint Check this box
    (the first 2 options should be unchecked)

    LAN
    General:
    IPv6 Configuration Type  Track

    Track IPv6 Interface:
    IPv6 Interface WAN
    IPv6 Prefix ID 0

    DMZ:
    General:
    IPv6 Configuration Type  Track

    Track IPv6 Interface:
    IPv6 Interface WAN
    IPv6 Prefix ID 1  (or anything between 1 and ff)

    Shutdown your box
    Reboot cable modem until its up
    Power your box back on



  • @doktornotor:

    You cannot use a single /64 for two LANs.

    Thank you for that. I saw when you choose /63, /62, …. it would let me do more prefixes, but then ipv6 did not seem to work what so ever.

    Where is the documentation for why that is so? I saw this elsewhere, but I couldn't find a reason for why.



  • @Cino:

    This works for TWC footprint in NYC/HV area.

    WAN
    General:
    IPv6 Configuration Type  DHCP6

    DHCP6 client configuration:
    DHCPv6 Prefix Delegation size /56
    Send IPv6 prefix hint Check this box
    (the first 2 options should be unchecked)

    LAN
    General:
    IPv6 Configuration Type  Track

    Track IPv6 Interface:
    IPv6 Interface WAN
    IPv6 Prefix ID 0

    DMZ:
    General:
    IPv6 Configuration Type  Track

    Track IPv6 Interface:
    IPv6 Interface WAN
    IPv6 Prefix ID 1  (or anything between 1 and ff)

    Shutdown your box
    Reboot cable modem until its up
    Power your box back on

    Thank you, I will try that when I get home!



  • If you run into issues, switch back to /64.. and you'll have to wait until your IPv6 prefix is released… usually 2-4 days... Oh, when you reboot your box down the road; dont expect the same IPv6 addresses. They will change unlike your IPv4 address.



  • I tried what you suggested (put /56), It worked, but I had to use also "Request only an ipv6 prefix". However once I did that, I got it to work!

    Thank you all for the help



  • Great!! I dont have it checked. I've had this setup for over a year now tho… Makes sense to check it since that is how its working in the first place.



  • this fixed it for me


Log in to reply