VirtualBox Upgrade V2.1.5 - V2.2



  • Hi all,

    I’m using pfSense for a year and a half now on two systems. One runs virtual (VirtualBox 4.2.16), and the other one is a physical system. Both perform exceptionally well (thanks to all involved  :D ) and never had an issue with one of these - 32 bit - systems, until now…

    Yesterday I ran the ‘auto update’ on the virtual machine. In advance of that, I always take a snapshot, but as said, never had to use that before. But after upgrading from v2.1.5 to v2.2, the system got stuck (picture). I restored the machine, took a full clone (without snapshots), and updated the FW again, but unfortunately: same result, same errors. So I downloaded the v.2.2 from the site, performed a new install, and restored the settings from my ‘old 2.1.5’ FW with the xml-file. This worked perfectly, great!

    But this morning the virtual machine got stuck OK, can happen, just not used to it… I rebooted the VM and could not find a single line of importance in the system log, so this was ‘a perfect freeze’. Now the FW worked fine again for almost three hours, but then the same happened, while the other VM’s were still running fine.

    However the cause will be hard to track without a log, I suspect a combination of my particular VirtualBox/OS (Windows) installation, and pfSense. Has anyone here also ran the update on an Oracle's VirtualBox machine already, and what are your experiences?

    Many thanks.

    However I’m quite sure v2.2 is reliable/stable I’m still a little concerned to update the physical system now. But maybe I shouldn’t  8)



  • Looks like a disk error to me.  I/O error when loading the kernel?  Don't expect it to write to the log if there is a disk I/O problem.



  • Looks like it indeed. But I don’t understand that, as this is a virtual disk. Besides, restoring the snapshot worked fine, so I don’t bother too much…

    The real issue I have now is that after installing a brand new (virtual) pfSense v2.2, the FW works perfectly fine, but crashes randomly for it seems like no reason (of course there is one…). I’ve never had that before.

    I’m sure that reinstalling the host will solve the issue, and I’m afraid I have to do so…

    I’ll post my experiences when that has been done. V2.2 looks very promising.



  • I've run 2.2 on both VMware Workstation, Virtualbox and ESXi.  No problems like that.  In fact, I've never seen a problem like that before with pfSense.



  • Agree. This should work fine, but it simply doesn’t and I can’t figure out why.

    The good news is that v.2.1.5 still runs fine for now, and I can restore the other VM’s after installing a new host.

    Thanks


  • Rebel Alliance Developer Netgate

    Looks like somehow the kernel file was truncated/cut off.

    Try a fresh install, and make sure the VM type and the install image are 64-bit (assuming your host system is 64-bit and has VT…)



  • Truncated… Interesting.

    The stable working 2.1.5 VM on my host uses 65% out of 445MB available disk space, which means that there is only 156MB available. Could it be that this caused the issue (screenshot first post) after invoking the ‘auto update’, even though the update package itself is about 80MB?

    Nevertheless and as you advise, I will perform a complete new (host) install soon.

    At the moment a 32 bit Windows version is installed on a 64 bit system, and yes, VT is present and enabled on the system. Never had issues with it, but now it's time to reinstall the machine

    Thanks  :)



  • *** Update - Problem Solved ***

    After pfSense version 2.2.1 was released, I downloaded the software and performed a brand new install for the second time. Now it also runs perfectly stable in combination with my Virtualbox setup. I still don't know what caused the issue in the first place, but it does not matter much anymore…

    One thing I noticed, there seems to be a huge improvement with the openvpn performance. It connects much faster, and I can get up- and download speeds up to 60Mbit, where I got 35 - 40 with the old version. Same settings, same hardware...

    I'm happy with it. Thanks to anyone involved! :)


Log in to reply