CARP not working after upgrade from 2.1.5 to 2.2



  • Dear All,

    after upgrading, I am facing issues which may be somewhat similar to this post (https://forum.pfsense.org/index.php?topic=87483.0).

    My setting consists of four C2758 machines, two per SOHO in two different cities connected via OpenVPN. The pair of machines per location is doubled up via CARP, working for many months now. Each location has two WAN connections and I am using Quagga routing.

    As far as I can tell, my setup is similar to figure 25.1 in the draft book plus dual WAN. Each machine has 6 NICs:

    igb0 WAN1
    igb1 LAN (via LAGG)
    igb2 SYNC
    igb3 WAN2
    igb4 LAN (via LAGG)
    igb5 LAN (via LAGG)

    Screenshots of the VIP overview and one example for the LAN on the master firewall are enclosed.

    After upgrading, CARP Status complains as the enclosed picture shows "CARP has detected a problem …". However, what the nature of the problem is, does not seem to be obvious from the logs.

    When powering up both the primary and the secondary firewall, CARP master and backup assignment does not seem to follow a straightforward pattern. Currently, I can only operate the system with the secondary firewall powered off.

    When having both firewalls on, OpenVPN does not work for clients connecting inbound to servers. Furthermore, adding the tradtional Qagga start and stop commands to /etc/rc.carpmaster and /etc/rc.carbbackup also does not seem to work. Possibly as a consequence of CARP not working, of course.

    Unfortunately, I am unable to make sense out of the information on CARP in the New Features and Changes page in terms of modifying my setting so that it would again work.

    Can someone please be so kind to point me to the right direction?

    Regards,

    Michael

    ![LAN VIP.gif](/public/imported_attachments/1/LAN VIP.gif)


    ![LAN VIP.gif_thumb](/public/imported_attachments/1/LAN VIP.gif_thumb)
    ![CARP Status.gif](/public/imported_attachments/1/CARP Status.gif)
    ![CARP Status.gif_thumb](/public/imported_attachments/1/CARP Status.gif_thumb)



  • Dear All,

    Experimenting further, I did try to exclude all risks I did conceive:

    • no traffic shaper in order to avoid "limiters" which may be critical

    • port forward rules all are WANx net as the destination address, never the Carp VIP interface

    • outbound NAT is automatic so that the NAT address is also the WANx address, never the Carp VIP interface - alternatively (same result) the automatic rules plus similar rules pointing to the Carp VIP interface as a NAT address

    Then, I made the following observations:

    • Both routers basically work - except for Carp and Quagga

    • The error message in Carp status is persistent

    • The Carp behaviour after rebooting routers is unpredictable. There are situations when e.g. one router is master for both WAN interfaces and the other router is master for both LAN interfaces (LAN and DMZ) which never happened before. When getting the secondry router to become master (e. g. by temporarily disabling Carp and then turning it back on), the secondary route stays master indefinetely despite skew 100 on its virtual IP address. This also never happened before the upgrade.

    • Quagga stays on no matter what. Watchdog is not even required to trigger it persistently. The classical line added to /etc/rc.carpmaster and /etc/rc.carpbackup does not have an impact.

    Can someone please provide some guidance / documentation?

    Regards,

    Michael



  • Has anyone posted a "Carp works great after update" post?


  • Rebel Alliance Developer Netgate

    Aside from CARP + Limiters, it's worked fine for all the ones I've seen/touched, both in testing and production.

    If carp is reporting a problem it's typically because one of the interfaces is down or a VIP is in init state, so it believes it should demote itself.

    Looking at the full output of "ifconfig -a" and "sysctl net.inet.carp" can help.

    The CARP error message is triggered by the net.inet.carp.demotion being > 0.



  • I have upgraded a CARP setup based on Xeon and Intel quad port NIC and everything works fine.



  • Dear Jim, dear all,

    Thank you very much for your feedback!

    As far as I can tell, the system behaviour is that CARP is always demoted. As a consequence, the set of routers does not prefer the primary box based on the skew = 0 anymore. The set of routers rather makes only one box master (good!) but just the box activated last, not prefering the primary (bad!). That means: If I temporarily disable CARP on one box and re-enable it, that box will become master (good/bad). If I only unplug a single interface, the last box reconnected will become master regardless of the other interfaces, i.e., each box can become master for some interfaces and backup for the others (bad/bad!!).

    In steady state (i.e., at least a few seconds after making any change), the log contains something like the sniplet below. Thereafter (and before) both systems will be demoted, but all interfaces will be up (further below, in that situation, the secondary system is Master, as it was re-activated last).

    Syncing seems to work all the time. At least, changes are copied and there are no notifications flashing.

    How can I escape this trap, please?

    Regards,

    Michael

    Jan 30 18:53:07 check_reload_status: Carp backup event
    Jan 30 18:53:07 kernel: carp: VHID 4@lagg0_vlan4: INIT -> BACKUP
    Jan 30 18:53:08 check_reload_status: Carp master event
    Jan 30 18:53:08 kernel: carp: VHID 2@igb3: BACKUP -> MASTER (master down)
    Jan 30 18:53:08 kernel: carp: demoted by 240 to 480 (pfsync bulk start)
    Jan 30 18:53:08 kernel: carp: demoted by -240 to 240 (pfsync bulk done)
    Jan 30 18:53:09 php-fpm[96030]: /rc.carpbackup: Message sent to michael@schefczyk.net OK
    Jan 30 18:53:09 php-fpm[96030]: /rc.carpbackup: Carp cluster member "192.168.1.1 - LAN CARP VIP (3@lagg0)" has resumed the state "BACKUP" for vhid 3@lagg0

    primary system:

    $ sysctl net.inet.carp
    net.inet.carp.allow: 1
    net.inet.carp.preempt: 1
    net.inet.carp.log: 1
    net.inet.carp.demotion: 240
    net.inet.carp.senderr_demotion_factor: 240
    net.inet.carp.ifdown_demotion_factor: 240

    $ ifconfig -a
    igb0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:e9:f7:c8
    inet 192.168.6.3 netmask 0xffffff00 broadcast 192.168.6.255
    inet6 fe80::225:90ff:fee9:f7c8%igb0 prefixlen 64 scopeid 0x1
    inet 192.168.6.2 netmask 0xffffff00 broadcast 192.168.6.255 vhid 1
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    carp: BACKUP vhid 1 advbase 1 advskew 0
    igb1: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:e9:f7:c9
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    igb2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:f3:8e:0a
    inet 172.16.1.78 netmask 0xffffff00 broadcast 172.16.1.255
    inet6 fe80::225:90ff:fef3:8e0a%igb2 prefixlen 64 scopeid 0x3
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    igb3: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:f3:8e:0b
    inet 192.168.0.3 netmask 0xffffff00 broadcast 192.168.0.255
    inet6 fe80::225:90ff:fef3:8e0b%igb3 prefixlen 64 scopeid 0x4
    inet 192.168.0.2 netmask 0xffffff00 broadcast 192.168.0.255 vhid 2
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    carp: BACKUP vhid 2 advbase 1 advskew 0
    igb4: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:e9:f7:c9
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    igb5: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:e9:f7:c9
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    pflog0: flags=100 <promisc>metric 0 mtu 33144
    pfsync0: flags=41 <up,running>metric 0 mtu 1500
    pfsync: syncdev: igb2 syncpeer: 172.16.1.79 maxupd: 128 defer: on
    syncok: 1
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    options=600003 <rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6>inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x9
    nd6 options=21 <performnud,auto_linklocal>enc0: flags=0<> metric 0 mtu 1536
    nd6 options=21 <performnud,auto_linklocal>lagg0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:e9:f7:c9
    inet6 fe80::225:90ff:fee9:f7c9%lagg0 prefixlen 64 scopeid 0xb
    inet 192.168.1.78 netmask 0xffffff00 broadcast 192.168.1.255
    inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255 vhid 3
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect
    status: active
    carp: BACKUP vhid 3 advbase 1 advskew 0
    laggproto lacp lagghash l2,l3,l4
    laggport: igb5 flags=1c <active,collecting,distributing>laggport: igb4 flags=1c <active,collecting,distributing>laggport: igb1 flags=1c <active,collecting,distributing>lagg0_vlan4: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=3 <rxcsum,txcsum>ether 00:25:90:e9:f7:c9
    inet6 fe80::225:90ff:fee9:f7c9%lagg0_vlan4 prefixlen 64 scopeid 0xc
    inet 192.168.4.78 netmask 0xffffff00 broadcast 192.168.4.255
    inet 192.168.4.1 netmask 0xffffff00 broadcast 192.168.4.255 vhid 4
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect
    status: active
    vlan: 4 vlanpcp: 0 parent interface: lagg0
    carp: BACKUP vhid 4 advbase 1 advskew 0
    ovpns1: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    options=80000 <linkstate>inet6 fe80::225:90ff:fee9:f7c8%ovpns1 prefixlen 64 scopeid 0xd
    inet 192.168.9.1 –> 192.168.9.2 netmask 0xffffffff
    nd6 options=21 <performnud,auto_linklocal>Opened by PID 22037
    ovpns2: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    options=80000 <linkstate>inet6 fe80::225:90ff:fee9:f7c8%ovpns2 prefixlen 64 scopeid 0xe
    inet 192.168.10.1 --> 192.168.10.2 netmask 0xffffffff
    nd6 options=21 <performnud,auto_linklocal>Opened by PID 22173
    ovpns3: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    options=80000 <linkstate>inet6 fe80::225:90ff:fee9:f7c8%ovpns3 prefixlen 64 scopeid 0xf
    inet 192.168.18.1 --> 192.168.18.2 netmask 0xffffffff
    nd6 options=21 <performnud,auto_linklocal>Opened by PID 22125
    ovpns4: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    options=80000 <linkstate>inet6 fe80::225:90ff:fee9:f7c8%ovpns4 prefixlen 64 scopeid 0x10
    inet 192.168.19.1 --> 192.168.19.2 netmask 0xffffffff
    nd6 options=21 <performnud,auto_linklocal>Opened by PID 23080

    secondary system:

    $ sysctl net.inet.carp
    net.inet.carp.allow: 1
    net.inet.carp.preempt: 1
    net.inet.carp.log: 1
    net.inet.carp.demotion: 240
    net.inet.carp.senderr_demotion_factor: 240
    net.inet.carp.ifdown_demotion_factor: 240

    $ ifconfig -a
    igb0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:e9:f6:a2
    inet 192.168.6.4 netmask 0xffffff00 broadcast 192.168.6.255
    inet6 fe80::225:90ff:fee9:f6a2%igb0 prefixlen 64 scopeid 0x1
    inet 192.168.6.2 netmask 0xffffff00 broadcast 192.168.6.255 vhid 1
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    carp: MASTER vhid 1 advbase 1 advskew 100
    igb1: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:e9:f6:a3
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    igb2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:f3:8b:82
    inet 172.16.1.79 netmask 0xffffff00 broadcast 172.16.1.255
    inet6 fe80::225:90ff:fef3:8b82%igb2 prefixlen 64 scopeid 0x3
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    igb3: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:f3:8b:83
    inet 192.168.0.4 netmask 0xffffff00 broadcast 192.168.0.255
    inet6 fe80::225:90ff:fef3:8b83%igb3 prefixlen 64 scopeid 0x4
    inet 192.168.0.2 netmask 0xffffff00 broadcast 192.168.0.255 vhid 2
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    carp: MASTER vhid 2 advbase 1 advskew 100
    igb4: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:e9:f6:a3
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    igb5: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:e9:f6:a3
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    pflog0: flags=100 <promisc>metric 0 mtu 33144
    pfsync0: flags=41 <up,running>metric 0 mtu 1500
    pfsync: syncdev: igb2 syncpeer: 172.16.1.78 maxupd: 128 defer: on
    syncok: 1
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    options=600003 <rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6>inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x9
    nd6 options=21 <performnud,auto_linklocal>enc0: flags=0<> metric 0 mtu 1536
    nd6 options=21 <performnud,auto_linklocal>lagg0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso>ether 00:25:90:e9:f6:a3
    inet6 fe80::225:90ff:fee9:f6a3%lagg0 prefixlen 64 scopeid 0xb
    inet 192.168.1.79 netmask 0xffffff00 broadcast 192.168.1.255
    inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255 vhid 3
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect
    status: active
    carp: MASTER vhid 3 advbase 1 advskew 100
    laggproto lacp lagghash l2,l3,l4
    laggport: igb5 flags=1c <active,collecting,distributing>laggport: igb4 flags=1c <active,collecting,distributing>laggport: igb1 flags=1c <active,collecting,distributing>lagg0_vlan4: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=3 <rxcsum,txcsum>ether 00:25:90:e9:f6:a3
    inet6 fe80::225:90ff:fee9:f6a3%lagg0_vlan4 prefixlen 64 scopeid 0xc
    inet 192.168.4.79 netmask 0xffffff00 broadcast 192.168.4.255
    inet 192.168.4.1 netmask 0xffffff00 broadcast 192.168.4.255 vhid 4
    nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect
    status: active
    vlan: 4 vlanpcp: 0 parent interface: lagg0
    carp: MASTER vhid 4 advbase 1 advskew 100
    ovpns1: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    options=80000 <linkstate>inet6 fe80::225:90ff:fee9:f6a2%ovpns1 prefixlen 64 scopeid 0xd
    inet 192.168.9.1 --> 192.168.9.2 netmask 0xffffffff
    nd6 options=21 <performnud,auto_linklocal>Opened by PID 41250
    ovpns2: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    options=80000 <linkstate>inet6 fe80::225:90ff:fee9:f6a2%ovpns2 prefixlen 64 scopeid 0xe
    inet 192.168.10.1 --> 192.168.10.2 netmask 0xffffffff
    nd6 options=21 <performnud,auto_linklocal>Opened by PID 45186
    ovpns3: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    options=80000 <linkstate>inet6 fe80::225:90ff:fee9:f6a2%ovpns3 prefixlen 64 scopeid 0xf
    inet 192.168.18.1 --> 192.168.18.2 netmask 0xffffffff
    nd6 options=21 <performnud,auto_linklocal>Opened by PID 57523
    ovpns4: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    options=80000 <linkstate>inet6 fe80::225:90ff:fee9:f6a2%ovpns4 prefixlen 64 scopeid 0x10
    inet 192.168.19.1 --> 192.168.19.2 netmask 0xffffffff
    nd6 options=21 <performnud,auto_linklocal>Opened by PID 61853</performnud,auto_linklocal></linkstate></up,pointopoint,running,multicast></performnud,auto_linklocal></linkstate></up,pointopoint,running,multicast></performnud,auto_linklocal></linkstate></up,pointopoint,running,multicast></performnud,auto_linklocal></linkstate></up,pointopoint,running,multicast></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,promisc,simplex,multicast></active,collecting,distributing></active,collecting,distributing></active,collecting,distributing></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast></performnud,auto_linklocal></performnud,auto_linklocal></rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6></up,loopback,running,multicast></up,running></promisc></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast></performnud,auto_linklocal></linkstate></up,pointopoint,running,multicast></performnud,auto_linklocal></linkstate></up,pointopoint,running,multicast></performnud,auto_linklocal></linkstate></up,pointopoint,running,multicast></performnud,auto_linklocal></linkstate></up,pointopoint,running,multicast></performnud,auto_linklocal></rxcsum,txcsum></up,broadcast,running,promisc,simplex,multicast></active,collecting,distributing></active,collecting,distributing></active,collecting,distributing></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast></performnud,auto_linklocal></performnud,auto_linklocal></rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6></up,loopback,running,multicast></up,running></promisc></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso></up,broadcast,running,promisc,simplex,multicast>



  • Dear All,

    I am still facing the issue that CARP is not working. The last interface coming up becomes master regardless of the skew setting.

    Could someone please be so kind as to write in a few words how the requirements for getting CARP to work in version 2.2 differs from what is written in the draft book on 2.1 in chapter 25, in particular the example redundant configuration on page 472ff ?

    From what I gather, CARP in 2.2 still generates an interface which reads like XXX.XXX.XXX.1 (LAN CARP VIP), i.e., the typical router IP on a typical LAN and XXX.XXX.XXX.2 (WAN CARP VIP), i.e. not the typical router IP on a typical WAN. Behind NAT, I suspect that one still has to create manual outbound rules translating to the WAN CARP VIP(s).

    Thank you very much,

    Michael


Log in to reply