Connect FTP server is too slow and must used Active mode



  • Hello,
    I was used Pfsense 1.2 release.
    I have create NAT the ftp port(21) and ftp-data port(20)
    And I have enabled FTP Helper.
    I found if I want connect FTP server it's must used Active mode.
    Could I use default settings passive mode?
    If can.
    How to set it?
    And I used Active mode.
    The connect still too slow and almost no respond.
    Thanks a lot.



  • Maybe your WAN is very loaded? Did you create the portforward for port 21 AFTER you enabled the ftp-helper at WAN? It's important that the ftp-helper is already running before you create the portforward as it will then create another rule for the ftphelper behind the scenes. If you have not done it in that order please do the following:

    • delete portforward for port 21
    • delete firewallrule for port 21
    • make sure ftp-helper at interfaces>wan is still enabled
    • create portforward for port 21 again (it will now tell you that it created 2 rules in the messagebox)
    • save, apply, be happy.

    Active and passive mode should both work now.



  • Hello,
    Thanks for your repond.
    I have reinstall the pfsense 1.2
    And I have check the default FTP helper is enabled.
    I have create new NAT for FTP 21 port and 20port.
    It's still too slow and when I from remote connect my FTP server.
    It's will this error message.

    [root@gateway7 ~]# ftp ftp.aspa.idv.tw
    Connected to aspa.idv.tw.
    220 ProFTPD 1.2.9 Server (ProFTPD) [web.aspa.idv.tw]
    500 AUTH not understood
    500 AUTH not understood
    KERBEROS_V4 rejected as an authentication type
    Name (ftp.aspa.idv.tw:root): akong
    331 Password required for akong.
    Password:
    230 User akong logged in.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp> dir
    227 Entering Passive Mode (192,168,2,250,140,161).
    ftp: connect: No route to host
    ftp>

    I want know what's wrong with it?
    I have enable FTP helper before settings NAT for FTP.
    And I want know.
    The WAN must enabled.
    Is FTP server network need enable FTP helper.
    And I have two LAN.
    Lan and Lan2.
    If I want from Lan connect to Lan2 FTP server.
    Have any something need to check?





  • OK,
    I was fix the speed too slow problem.
    But I have got error message.
    I can very fast connect to the FTP server.
    I also can login and all success.
    But when I want show file or directory with use dir command.
    I found is show
    Using binary mode to transfer files.
    ftp> dir
    227 Entering Passive Mode (192,168,2,250,140,215).
    ftp: connect: No route to host
    "192.168.2.250" is my OPT IP address.
    The remote is want connect it.
    How to fix it?
    I know can use Active mode can fix it.
    But if user use IE browers it's can't connect.



  • Looks like your ftpserver hands out his private IP to the client. Check your ftpserver's manpage to see how to make it aware of it's public IP.


Locked