My lovely IBM Dual Port Server Adapter is not recognized



  • Well, I've just moved pfSense to the Via machine I want to run it, but I had to install a meesly single port PCI card to it, as FreeBSD didn't recognize my dual nic server card.

    It's a 64-bit PCI, but I wouldn't be able to utilize the extra speed as the VIA board is only 32-bit, but it's a shame having it lying around, when it would fit neatly into the Via box :-)

    Full name of the card is IBM 10/100 Dual Port Server Adapter Card P/N 22P4919, it based on Intel Chips.

    Would be lovely it it could be used  ;D



  • Check your biossettings for upnp os. If there is a setting for it set it to "no" and retry.



  • I tried both with Yes and No, it only shows the Via ITX nic.



  • @fribert:

    Full name of the card is IBM 10/100 Dual Port Server Adapter Card P/N 22P4919, it based on Intel Chips.

    Which Intel chip?  Not every chip is supported by FreeBSD, so knowing which one would help ;)



  • From IBMs web site: http://www-304.ibm.com/systems/support/supportsite.wss/docdisplay?brandind=5000008&lndocid=MIGR-4XEJ5P

    The new 10/100 Dual Port Server Adapter, Options part number (P/N) 22P4901 is a low power, high performance PCI 2.2 10/100 Dual Port Ethernet Adapter based on latest Intel 82550 C-step technology. The adapter is 64-bit / 66 MHz so it is capable of running in either 32-bit or 64-bit PCI slots at 33 MHz or 66 MHz PCI Bus…

    Is the adapter shown on the boot screen or even detected in DMESG  https://<pfsense-ip>/status.php#DMESG

    Should look like this:
    fxp1: <intel 100="" 82558="" pro="" ethernet="">port 0x3400-0x341f mem 0xf4400000-0xf4400fff,0xf4200000-0xf42fffff irq 7 at device 4.0 on pci2
    miibus1: <mii bus="">on fxp1
    inphy1: <i82555 10="" 100="" media="" interface="">on miibus1
    inphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    fxp1: Ethernet address: 00:50:8b:…
    fxp2: <intel 100="" 82558="" pro="" ethernet="">port 0x3800-0x381f mem 0xf4401000-0xf4401fff,0xf4300000-0xf43fffff irq 9 at device 5.0 on pci2
    miibus2: <mii bus="">on fxp2
    inphy2: <i82555 10="" 100="" media="" interface="">on miibus2
    inphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    fxp2: Ethernet address: 00:50:8b:...</i82555></mii></intel></i82555></mii></intel></pfsense-ip>



  • I've tested it now (something to do in the easter :D).
    When I tried installing from the ISO, it failed to detect it, so I put in a lowly 3COM which it found immediately.
    I just shut the firewall down yesterday, and tried putting in the IBM card.
    When it booted up again, it detected it perfectly, asking me to assign WAN and OPT1.
    A bit of a difference there, between the ISO installation and bootup for some reason.

    Well it works, so I'm a happy camper, very nifty tiny firewall, with three NIC's now, all made from 'scrap metal'  ;D


Locked