SquidGuard-squid3 can't start any more



  • Hello Every one

    i am getting a lot of problem after upgrading to the 2.2

    i doo a fresh install and i start to reconfigure all modules one by one
    now every think work well except the squidGuard-squid3 can't start any more

    my build
    2.2-RELEASE (i386)
    built on Thu Jan 22 14:04:25 CST 2015

    the squidGuard-squid3 version is 1.4_7 pkg v.1.9.6
    the squid3 version is 3.4.10_2 pkg 0.2.6

    error Log : from /var/log/squidGuard.log

    2015-01-26 02:48:50 [6298] /usr/local/bin/squidGuard: can't open configfile  /usr/local/etc/squid/squidGuard.conf
    2015-01-26 02:48:50 [6298] Going into emergency mode

    what i can't understand that the config file should be in  /usr/pbi/squidguard-squid3-i386/etc/squidGuard/squidGuard.conf  why the squidGuard is looking on this path  /usr/local/etc/squid/squidGuard.conf

    please help

    sacaman



  • To make it working i should connect to the SSH console and start this command

    [2.2-RELEASE][root@pfSense.xxxxxxxx.com]/root: squidGuard  -C all -d
    2015-01-30 21:41:10 [62896] New setting: dbhome: /usr/local/share/examples/squidGuard/blacklists
    2015-01-30 21:41:10 [62896] New setting: logdir: /var/log/squidGuard
    2015-01-30 21:41:10 [62896] Added User: root
    2015-01-30 21:41:10 [62896] Added User: foo
    2015-01-30 21:41:10 [62896] Added User: bar
    2015-01-30 21:41:10 [62896] destblock good missing active content, set inactive
    2015-01-30 21:41:10 [62896] destblock local missing active content, set inactive
    2015-01-30 21:41:10 [62896] init domainlist /usr/local/share/examples/squidGuard/blacklists/porn/domains
    2015-01-30 21:41:10 [62896] Error db_open: No such file or directory
    2015-01-30 21:41:10 [62896] Going into emergency mode

    CTRL +C

    and squidGuard already start



  • Hello,
    Thank you for the command, but I'd like to automate it, how could I do?
    sorry for my english  ;D



  • to do so

    remove the squidGuard-squid3 version 1.4_7 pkg v.1.9.6

    and install squidGuard-devel 1.5_1beta pkg v.1.5.6 reconfigure it

    reboot and enjoy



  • the SquidGuard dev version installed and it's running but still not filtering.
    I check the Squid setting and it reset the transparent proxy settings and SSL filtering.
    After Setting the squid proxy transparent settings, it works :)



  • @sacaman:

    to do so

    remove the squidGuard-squid3 version 1.4_7 pkg v.1.9.6

    and install squidGuard-devel 1.5_1beta pkg v.1.5.6 reconfigure it

    reboot and enjoy

    But squidGuard-Devel does not work with squid3 when I reboot the pfsense with squid-devel both are stopped, with Squidguard-squid3 the problem is that the service is stopped squidguard and the only way to start is to squidGuard -C all -d



  • hi,

    try to setup the squid proxy to the transparent mode and reboot



  • Hi,

    Same case here. We have a pfsense 2.2-RELEASE (amd64) built on Thu Jan 22 14:03:54 CST 2015. With the installed packages:

    squid3 -> 3.4.10_2 pkg 0.2.6
    squidGuard-devel  -> 1.5_1beta pkg v.1.5.6

    Transparent proxy mode on and the only way to make it work is to launch a blacklist update in the gui or in the shell with:
    squidGuard -C all -c /usr/pbi/squidguard-amd64/local/etc/squidGuard/squidGuard.conf

    The the squidguard works well.

    Does anyone get this fixed?

    Bye.



  • having the same problem, after resetting pfSense to factory settings and reinstalling the squid and squidguard package, all work normally



  • Same issues. Squid crashing / stopping or squidguard not filtering.

    Did a clean install today with exactly same results.
    Infuriating as it is, I have an exact same setup running without issues.

    not planning on touching either package with a 10foot pole for a while till they are stable.



  • I would prefer no to reinstall the whole system. I've tried to uninstall the packages delete al related files, reboot and reinstall and the problem persist  :(



  • Hi,

    i've updated the system to the latest pfsense 2.2.1 and the problem persit  :( I've done a workarround by creating a file in /usr/local/etc/rc.d/ with the content:

    !/bin/sh
    /usr/pbi/squidguard-devel-amd64/bin/squidGuard -C all -c /usr/pbi/squidguard-amd64/local/etc/squidGuard/squidGuard.conf &
    /usr/local/sbin/squid -f /usr/pbi/squid-amd64/local/etc/squid/squid.conf -k reconfigure

    With this workarround the squid/squidguard is running after system (re)start.



  • Yep, did a full re-install and installed squid3 and squidguard-devel and all is working, except antivirus on squid3.

    UPDATE: Clicked SAVE twice on antivirus settings of squid3, addressed stated config errors in red, and now antivirus is  working.

    Snort, Squid3, and Squidguard-devel help contribute to make pfSense one hell of a firewall.


Log in to reply