Can't add interface - plus / add button is missing



  • In webGUI, I go to:  menu -> Interfaces -> assign

    the add button is missing (only an "X" for the LAN).  I only have WAN and LAN and want to add OPT1.  I switched to the other slice, but the add button is missing as well.

    What should I try?

    nanobsd, 4GB ram, cpu: atom D2500 1.8 ghz, pfense 2.1.5 (amd64)



  • in my myopic concentration in setting up an openVPN (client) on pfsense, I have come to realize that I need a physical interface to assign to OPT1, i.e., it can't be virtual.  I assume that is why the add ("+") button is missing.  If I'm correct in this, please let me know and I'll either:

    1. buy another nic or
    2. configure the openVPN to use the WAN interface.


    intel D2500cc



  • what type of virtual interface are you trying to add and to where?


  • Netgate

    You can add an openvpn instance as an interface.  If properly configured and enabled it should show up as an available interface and enable the add interface button.

    ETA:

    1. buy another nic or
    2. configure the openVPN to use the WAN interface.

    What, exactly, are you trying to accomplish?



  • @Derelict:

    You can add an openvpn instance as an interface.  If properly configured and enabled it should show up as an available interface and enable the add interface button.

    What, exactly, are you trying to accomplish?

    I'm trying to setup pfsense as an openvpn client according to the steps in this post:
    https://forum.pfsense.org/index.php/topic,66467.0.html


  • Netgate

    That guide is in the wrong order.  After you create the openvpn client instance it will be available for interface assignment.

    The create interface button is only displayed if there are unassigned interfaces.



  • @Derelict:

    That guide is in the wrong order.  After you create the openvpn client instance it will be available for interface assignment.

    The create interface button is only displayed if there are unassigned interfaces.

    thank you - you are correct - that solved it - I was able to quickly get everything working and can direct certain clients to use OPT1 as the gateway and others the WAN.

    the only issue is the "Gateways" widget - it is showing offline, even though I have devices using it as the gateway to the openvpn server.



  • Netgate

    I would just turn off gateway monitoring on the openvpn client interface unless you're going to try to automatically failover to/from it.

    You can't ping an openvpn internal interface like that because there's no interface to ping.  It's weird.  So your options are to deal with the gateway showing down, find something on the OpenVPN provider's network to use as an alternate monitor IP address that you can ping and is contained in the routes you have going to that provider, or just disable monitoring on the gateway.



  • @Derelict:

    You can't ping an openvpn internal interface like that because there's no interface to ping.  It's weird.  So your options are to deal with the gateway showing down, find something on the OpenVPN provider's network to use as an alternate monitor IP address that you can ping and is contained in the routes you have going to that provider, or just disable monitoring on the gateway.

    good clarification.  I decided to not disable monitoring for the OPT1 gateway and I typed in the "Alternative monitor IP"  the IP of the openVPN server.  This way I can see the quality of the connection in the RRD Graphs.



  • I'm seeing the add buttons missing in the interface assign page. Only delete on all but the WAN interface.


  • Netgate

    Then you don't have any unassigned interfaces available for assignment so the button doesn't appear.