Getting vnstat2 to work with pfSense 2.2



  • To get vnstat2 to work with the new 2.2 release, I had to do the following

    • mkdir -p /var/lib/vnstat

    • install vnstat2

    • edit /usr/local/www/vnstat2/config.php

    Inside config.php I had to change the $iface_list array to be the name of my LAN interface and the GUI started to work.



  • tried it on a test box and it worked for me.

    Any chance the package can be updated to work without this workaround?


  • Rebel Alliance Developer Netgate

    I pushed some fixes today. Should be fine now without manual changes.



  • I can confirm the latest package works as expected.

    Thank's for your effort.



  • Woohooo!!!

    Thanks Jimp!!



  • While the new update makes vnstat work, the old data is lost.

    Any chance there is a way to migrate the data, or at least not lose the data when it does the update?  I hate to lose my data.  I had to switch back to 2.1.5.  If there is no way, then I have to wait till next month's billing cycle.


  • Rebel Alliance Developer Netgate

    As far as I can see they put the data in the same place (/conf/vnstat/<nic_name>/), same with the new as the old. I didn't have any old data so I can't say why it might not have converted. Both 2.1.x and 2.2 use the same vnstat code so if you have the same vnstat on both then perhaps some other difference made the data change in some way or become invalid.</nic_name>



  • Did you change arch by chance? I've upgraded my box many times over the years with no major issues to vnstats data (always back it up in case it gets deleted). I went from 2.1.5 i386 to 2.2 amd64 and couldn't reuse my previous vnstat data. I'm ok with it since I knew it would be a risk because of arch change.


  • Rebel Alliance Developer Netgate

    Another possibility is that your upgrade changed the NICs, for example on Xen the NIC names could have changed from, say, re0 to xn0. Renaming the database dirs in /conf/vnstat would fix that.



  • No change to arch.  Machine is a VM, if there is a NIC change it's not my doing.

    I'll give it another try and hopefully this and squidguard will work again.  Once a week I try to upgrade to 2.2 in hopes the packages upgrade. :)



  • error install vnstat pfsense  (vnstat1.12.6  )http:// x.x.x./vnstati.php