Can't start Squid



  • Hello
    I'm trying to install squid and squidguard to block certain categories of site and I've installed, and uninstalled several packages several times.  I have recently upgraded to pfSense 2.2.

    After removing everything, I have now installed just  "squid Network 2.7.9 pkg v.4.3.6".  I've set it for a transparent proxy but it won't start.
    I can't see any errors in the log.

    Can anyone guide me - have I missed something obvious and which logs will help me?

    Thanks
    Andy



  • Sadly, this package appears to have missing dependencies. Take a look at 'Status', 'System Logs', 'System' just after attempting to start Squid and you will see for yourself.

    I don't know how the package system works, but this package should come with some sort of warning in the description that it doesn't work on a fresh 2.2 installation.


  • Rebel Alliance Developer Netgate

    For now, use the squid 3 package.



  • Hi, sorry to Hijack this, but i am having same issue,

    i have since reverted back to 2.1.5 but squid wont start. should i do a clean install or go for squid 3?

    thanks



  • On 2.1, you can use any squid version.

    On 2.2 amd64, use squid3.



  • i am on still using the x86 version of 2.1.5



  • After the auto upgrade i got similar issues as everyone, squidGuard-squid3 will not start:

    Feb 6 00:13:57 php-fpm[92018]: /pkg_edit.php: [Squid] - Squid_resync function call pr:1 bp: rpc:no
    Feb 6 00:14:00 php-fpm[92018]: /pkg_edit.php: Reloading Squid for configuration sync
    Feb 6 00:14:00 check_reload_status: Reloading filter
    Feb 6 00:14:01 php-fpm[13857]: /rc.filter_configure_sync: The command '/sbin/pfctl -nf /tmp/rules.test.packages' returned exit code '1', the output was '/tmp/rules.test.packages:25: syntax error'
    Feb 6 00:14:01 php-fpm[13857]: /rc.filter_configure_sync: There was an error while parsing the package filter rules for /usr/local/pkg/squid.inc.
    Feb 6 00:14:02 php-fpm[13857]: /rc.filter_configure_sync: The command '/sbin/pfctl -nf /tmp/rules.test.packages' returned exit code '1', the output was '/tmp/rules.test.packages:24: syntax error'
    Feb 6 00:14:02 php-fpm[13857]: /rc.filter_configure_sync: There was an error while parsing the package filter rules for /usr/local/pkg/squid.inc.

    What to do until it's fixed?
    When will it be fix?

    Thanks



  • @jimp:

    For now, use the squid 3 package.

    Sorry I don't understand what you mean?
    squidGuard-squid3 has filter which squid3 does not have how can squid3 do the same job?



  • Sorry I don't understand what you mean?

    The person Jim was replying to was using Squid2 (" I have now installed just  "squid    Network  2.7.9 pkg v.4.3.6"…..")  Jim told him to use Squid3.


Log in to reply