• Hi all!

    I am new to the forums and to PFSense. I am an avid reader on Overclock.net (I don't comment much due to lack of true knowledge, I read to learn). I ran into some information and threads about running PFSense as a routing solution and was intrigued. I have been working on preparing and installing PFSense to an old computer to use as firewall/routing solution for my home. I am relatively security conscious and I felt that I could do better than the off-the-shelf router that I have. The computer I have is still overkill for PFSense, but I planned on running SQUID, Snort, and some form of AV, maybe. Planned on under-clocking once everything was setup to reduce power usage. Honestly this was going to be a proof of concept before purchasing a couple of dedicated mini-ITX boards in a CARP setup.

    Anyways..I have been having trouble with the initial setup and I am wondering if anyone has a solution.

    Situation:
    I downloaded the USB live version 2.15 and wrote the image to a freshly formatted flash drive. I then booted off of that drive and designated my two NICs (one WAN, one LAN). Once I designated the NICs, I installed to disk. I setup a dual boot with Windows 7 (didn't want to lose the key, though I figured I would never use it again). It seemed to boot up just fine and I then assigned IP addresses to the two ports. However when I actually plug in the network cables to the ports, the workstation locks up and becomes in-op. I figured maybe the network cables have to be plugged in prior to boot up, so I shut down the station, remove power, then boot up with the cables already connected. This time it didn't make it past "Configuring the WAN connection." I read that it takes a while, but I left it up for 12 hours and nothing.

    I then think.. OK lets try 2.2. This time I wiped the entire drive (so long Windows 7 Ultimate..), but I ran into the same issue. I tried removing the WAN cable on boot, but then it stalled on the LAN configuration.

    I'm thinking maybe it is a hardware issue (probably the NICs).. I think the NICs are Marvell with the nVidia 970 chipset.

    Hardware:
    Processor: AMD AthlonII dual core at 2.8GHz (I think).
    ASUS M2N-SLI Deluxe
    8 GB of Samsung DDR2-667 RAM
    320GB WD Green drive


  • It sounds like the NICs aren't playing nicely, though the root cause could be something about the system and its interaction with the NICs. The first thing to check is whether you have the latest BIOS on the system. Often times BIOS updates fix hardware bugs that are either worked around in software or don't exhibit themselves with Windows. If that doesn't help, try resetting the BIOS to factory defaults. It's possible something got set oddly at some point and setting things back to defaults will make it work. If there is any hardware you're not using that you can remove, remove it. Any extra things like onboard sound cards that aren't in use, disable in the BIOS.

  • Netgate Administrator

    That board is specifically mentioned as supported by the nfe(4) driver. I assume your NICs appear as nfe0 and nfe1?
    One issue that is also mentioned is:

    Several errors are caused by shared interrupt with another device (e.g. USB device). One solution is to disable the shared device in the BIOS. Another solution is to enable the polling mode.

    Don't use polling. Not that you can from this situation.  ;)

    Check the BIOS and boot logs for devices sharing the same interrupt and see if they can be disabled.

    There also seems to be some indication of Windows putting the NICs in some odd mode that isn't removed by rebooting so if you haven't actually pulled the plug completely on the box try that.

    Steve


  • They are indeed nfe0 and nfe1.

    I will need to check the BIOS, take a look at what's going on, and probably reset to defaults first, then try disabling the sharing. Would disabling the device sharing (USB sharing) disable the USB ports? Apparently I need to google a bit more and find the documentation for the Marvell drivers.

    Thank you guys for responding. While this isn't a mission critical thing in the household network, my wife would really prefer it if our office didn't look like my playground; so I can use all the help I can get to get the ball rolling on this project.

  • Banned

    There's a galore of useless stuff to be disabled on that board via BIOS, starting with the onboard sound, FireWire, IDE, LPT. After that, any interrupt sharing will probably become a non-issue.


  • After resetting the BIOS to the default settings twice, I got PFSense to boot correctly. Tomorrow I will go back into the BIOS and disable the non-essentials and hope for the same results.

    Thanks everyone for helping me out with this. Hopefully I won't run into any more issues.