Problem upgrading from 2.1.5\. to 2.2 on fit-PC2i



  • Hi, just upgraded my fit-PC2i http://www.fit-pc.com/web/products/fit-pc2/ from 2.1.5 to 2.2 and got some errors, please see pic. Also, when trying to navigate the UI it throws "500 - Internal Server Error".

    I checked the "Backup before upgrade" checkbox, but i don't know where the b/u is stored :-(.

    I know I got sloppy here, but this fantastic product have worked and worked without any hiccups, and through upgrades since 2011/2012.

    I am really not a FW or linux guru so all help is much appreciated.
    Thanks
    Mike


  • Banned

    You clearly did NOT upgrade. See the version information.



  • Well, the upgrade did not complete, I can read that  :P

    Any usefull hints on how to get to a known state, or how I retrieve my config before a re-install?


  • Banned

    If you have a configuration backup then just do a clean 2.2 install and restore the config.



  • As I just wrote, I need help on how I get the configuration backup - or restore the previous working state.

    Since I ticked the "Backup before upgrade" checkbox i hope the backup is stored somewhere on the host and that someone could guide me to how I retrieve it.


  • Banned

    Sigh. Really, people, what's so hard about doing a backup of the configuration before upgrade, saving it locally? Would totally seem like a common sense. There is a full backup tgz under /root (pfSense-full-backup-YYYYMMDD-HHMM.tgz, somehow I strongly doubt it's gonna be restored successfully with current state of the box though.

    Download /cf/conf/config.xml via SFTP. Or download the tarball and extract it from there.



  • If your pfsense wasn't highly configured, I'd just wipe and reload.  If it was highly configured, track down that backup, wipe, reload and restore.

    Always backup - And when I say backup, I mean log in with your windows/linux/bsd browser on some desktop and save a backup in your downloads.

    Then have fun updating.  (BTW - I've done the same thing before, so, I'm part of the stupid club)



  • That looks very much like what happens when your drive dies, it's failing to write to disk. That or the disk really is full, like maybe the full backup ended up bigger than the space available on your filesystem (which is generally rare, but with some packages like Squid with a good sized cache, it's more likely to happen).

    Check the disk usage on the dashboard, or the output of "df -h" to see how much disk space is used. If it's 100%, go to System>Firmware, Restore Full Backup tab, and delete the backup there. If it's not 100% used, then your drive is dead. Replace it, reinstall, restore your config backup.


  • Banned

    Well, there's "no space left on device" directly on the screenshot…  Though, not sure whether it does not relate to /tmp on a manually configured ramdisk.



  • @doktornotor:

    Well, there's "no space left on device" directly on the screenshot…  Though, not sure whether it does not relate to /tmp on a manually configured ramdisk.

    "no space left on device" is a common symptom of a dead drive, where that appears and the drive isn't really full, that's the issue.
    https://doc.pfsense.org/index.php/Filesystem_Full_/_Out_of_Inode_Errors

    It's a full install, so I assumed the usual /tmp being on the drive. If /tmp is enabled as as RAM disk, it might a diff issue entirely. In that case, /tmp is likely too small for what's running on the system.



  • Wonder if he can get to diagnostics > smart status to see if smart is reporting failures?



  • This:
    @doktornotor:

    …...
    Download /cf/conf/config.xml via SFTP. ......

    is the most simple - and imho the best - advise.
    And easy to realize.

    Download FileZilla - an free FTP/SFTP client program from here https://filezilla-project.org/
    To connect to you pfSEnse, use:
    Your pfSEnse IP.
    The user will be 'root' (and NOT 'admin')
    The password will be the same as what you used as the 'admin'.
    The port will be '22' (no, not 21)
    And now the difficult part, do not use the FTP¨protocol but the "SFTP - SSH File Transfer Protocol".
    Click on "Connect" and your in.

    (No I cross my fingers for you and hope that the ssh daemon is actually running …..)



  • I agree, but before he bothers reinstalling to that drive I just think it would be great to check its health.

    Thats all.



  • Thank you all for trying to analyze my problem. However, the HDD doesn't seem to be the issue. I am more than ever confused, but I think I have some clues for the smart guys here at the forum. This is what I have done since yesterday.

    Actions

    • bought and installed a new hard disk
    • did a clean install of 2.2 (pfSense-memstick-2.2-RELEASE-i386-20150122-1404) on the new HDD
    • got warnings in the final stage of the installation (at the Console menu): incorrect date() and corrupt Config.xml 0 bytes,
    • also, most of the options i the Console meny did just reload the menu and the warnings above, but did not execute the action, eg 1) Assign Interfaces just "refreshed" the screen.
    • did a clean install of 2.1.5 instead. Everything looked just fine all through the installation and i restored connectivity on both network interfaces.
    • but when I "restored" a year old configuration backup the initial problem reoccured - with identical text (please see my pic in the initial post in this thread).
    • so I did one more clean install of 2.1.5, run the install Wizard. No error! Saved the config.
    • then i changed, in the Advanced Settings, the "TCP port" and checked "Secure Shell Server", and the exact same error returned!

    I am currently running the firewall with these error but i don't know if it will degenerate as the last time and finally stop, or if this stage is pretty "stable" until i try a new upgrade…

    I don't know what more information i can provide to facilitate the analyze of the problem - just let me know!

    Maybe a stupid thought, but could this be a problem with file or folder permissions introduced in a previous upgrade, since it obviously is not a HDD hardware error.



  • ;D This is a humble bump of my post, please if someone can give me a hint of how I can analyze this problem, thanks /Mike



  • First, I have to say that it is really strange that fit-pc models do not have proper attention here, I think they are quite good for running pfSense.

    I have fit-pc2i myself and was running it for a year now with almost no issues.
    Almost - because wifi gave me some issues - only worked for several hours in AP mode and then signal disappeared. I did not really need access point, so I ignored it eventually.

    Here comes today, when I decided to upgrade to 2.2… and it did not work. It core dumped after upgrade on first reboot. On next reboot it shows similar errors on the console. Those errors indicate that filesystem is corrupted, possibly because of core dump during previous boot.

    I did some tests, looked at the core dump data and realized that the issue is this - Bug #4175 - kernel panic when loading run driver for RT3070 - pfSense is crashing while loading driver for RT2870 wifi card.

    I could not find any workaround at it was getting late, so I did physical fix - just removed wifi card from fit-pc2i.
    It is easy to do, you just need a screwdriver and 5mm hex socket. It supposed to be a mini-PCIe card, but mine turned out to be a very small board, smaller than mini-PCIe, affixed where mini-PCIe should be and connected to a separate connector on the motherboard using wires. Oh, and it won't be easy to install different card there because of missing nuts for mini-PCIe mounting.

    Anyway, pfSense 2.2 installed fine once wifi was removed and I restored configuration without any issue.

    I am now thinking of upgrading to their new fitlet-i or fitlet-X model, but the question is how to make sure that hardware is compatible…



  • If you're having difficulty upgrading your fit-PC2i to pfSense2.2 here's a workaround that will disable your wireless card and allow you to run 2.2 without opening up your case and removing the card:

    Press ESC at the first Welcome menu. This will drop you into bootloader configuration where you'll see an OK prompt. Enter the command 'set hint.run.0.disable=1' followed by 'boot'. This should allow you to complete the boot sequence. At the pfSense menu open a shell and add the line 'hint.run.0.disable=1' to /boot/loader.conf.local so that you'll be able to reboot without repeating this procedure again. When the bug in the RT2870 driver is fixed, just remove this line. You'll have access to your wireless card on the next reboot (and as per dgcom's experience, maybe it'll work better).

    I gotta agree about how great a firewall the fit-PC2i makes. I've been running ubuntu/ebox on it for years and am moving to pfSense since the Zentyal project recently gave up supporting their firewall modules. I should have made the move a long time ago!



  • Well, I found 'set hint.run.0.disable=1' later on, after I was able to restore Internet connectivity at home :)
    That's a good tip, but you have to be careful - if missed, booting and crashing caused many filesystem errors in my installation…


Log in to reply