Squid and pfSense 2.2 page timeouts



  • I'm new to pfSense and am trying to get Squid working.  I just did a clean install of pfSense 2.2 and then I tried to enable Squid 3 beta package.  It was working fine except for a few websites would give me request timeout errors.  Mainly from google search results.  I uninstalled squid 3 and tried going back to 2.7.9_4 and then I got errors like this instead of just timeout errors.

    Being new, and with a fresh install, I'm at a loss as to what to look at to fix it.

    ERROR
    The requested URL could not be retrieved

    While trying to process the request:

    GET /url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&ved=0CCAQFjAA&url=http%3A%2F%2Fspeedof.me%2F&ei=DvbSVLvdAYqjyASLvIDAAw&usg=AFQjCNEm4OH0m_SV2q6vpmyBtGHRUpqTBQ&bvm=bv.85142067,d.aWw HTTP/1.1
    Host: www.google.com
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8
    Accept-Language: en-GB,en;q=0.5
    Accept-Encoding: gzip, deflate
    Cookie: PREF=ID=d97198f5ad17509c:U=136a8a050c11b4b4:FF=0:TM=1423030572:LM=1423030572:S=9dYj6GWQ-CQJaCa4; NID=67=whYGVQcsIpRVPIrTrXDXgnFmeOJ04w945eajoskcHpR5XEqc8B54T04o_ZZ0R7ek2toWqyPtsRZowistNrl8K4veNni7xrXRw59ZUFiBAUDRMkC4kVUKPEh4O_ZnCJxa; OGPC=5061416-1:; OGP=-5061451:
    Connection: keep-alive

    The following error was encountered:

    Invalid Request

    Some aspect of the HTTP Request is invalid. Possible problems:

    Missing or unknown request method
        Missing URL
        Missing HTTP Identifier (HTTP/1.0)
        Request is too large
        Content-Length missing for POST or PUT requests
        Illegal character in hostname; underscores are not allowed



  • Just reinstall it and that should fix it.  Go to Packages and click on the small PKG button to reinstall it.  Once that's done, it should just work.  I've seen this at least a dozen times now where the initial install doesn't work but a reinstall does.



  • I have tried that with Squid 2, and it still gives me the exact same error.  Other suggestions?



  • Don't use Squid2.  Use Squid3.



  • Thanks for the info.  In playing around with things I really broke some other things I was trying to setup, so I wiped the server and reinstalled.  One thing I did differently was after installing squid3, I restarted it immediately, and now the problem seems to have gone away.

    Thank you for the help.


Log in to reply