Openvpn client and failover on 2.2



  • Hi,
    I am reading past threads but I have not found a definitive reply.

    I have two pfsense boxes in HA and I have also two wan for load balancing.
    I have put an openvpn client, it runs correctly only on master but it uses always first wan for going trying to connect to the server.
    If I disable first wan I lose the vpn.
    I would like to know if it is true that openvpn client does not follow load balancing rules even in 2.2.
    What can I do in this case?

    Thanks,
    Mario



  • Make a gateway group with WANmaster = tier 1, WANother = tier 2.
    Select the gateway group as the interface on the OpenVPN client.
    Then it will bind and connect out from whichever is the highest tier WAN in the gateway group that is up.
    It will fail over and back as the WANs go down and up.

    This should all work with HA also, although I haven't tried all that.



  • I have tried and I get this error:

    "An IPv4 protocol was selected, but the selected interface has no IPv4 address"

    Is this due to the fact that I have an openvpn CLIENT?

    Thanks again,
    Mario



  • I have seen problems when selecting a DHCP WAN that does not yet have an IP address.
    It happens for setting up various things, because the code is a bit dumb - the WAN interface does not yet have a real IPv4 address, and so the code complains that you cannot use it for IPv4 purposes.

    I think you need to get all the WANs to be up (at least have received their DHCP IPv4 addresses) in order to save the configuration in the webGUI.

    I have found this annoying in the past when trying to setup failover when the failover WAN is actually something that is not plugged in (and is only plugged in when needed).


Log in to reply