[RESOLVED] Upgrade from 2.1.5 -> 2.2: DNS not resolving FQDN's

  • Hello all.

    Just wanted to document what I just went through, in updating to 2.2. My hope is that it might help someone else…

    Auto upgrade worked as planned; machine rebooted, GUI came up, etc. Had a couple packages that didn't start (bandwidthd and arpwatch), so I removed them. Upgraded SNORT, it started just fine.

    What didn't work so well, was accessing the WAN. I could ping via IP ( ) but I couldn't ping via FQDN (google.com). First instinct: DNS. Because this was an upgrade, I was still using DNS Forwarder, not Resolver. Everything was configured correctly for the Forwarder but I disabled it, and moved over to Resolver thinking something was "stuck", etc. Reboot -> same issue.

    After trying unsuccessfully to change / tweak DNS Resolver settings, DNS IP's (in the General Setup area), DHCP settings, Firewall, etc., I ended up stumbling across my Gateways. I only have 2 configured (WAN/LAN) and noticed that neither one was checked to be the default gateway ( Clicked on WAN, checked "default gateway", my Spotify started playing almost immediately after applying the change.

    Not sure what happened during the upgrade but my default gateway entry was left empty. Drove me nuts for a couple of hours... lol

    Hope this helps someone, somewhere, at some point. ;)

    tl;dr: verify you have a default gateway either checked (System: Gateways) or one in your routing table (for larger installs).

  • Hm, that should have never worked. What type of WAN do you have? Static or DHCP or?

  • Rebel Alliance Developer Netgate

    I believe at some point Ermal had some logic in to ensure that one gateway was always default, if no others were chosen it took the first in the list. Though between various gateway cleanups for handling multiple overlapping/same-name entries it's hard to tell if that was lost or if some other config oddity we fixed changed the behavior.

  • I think it's good for me to do it.

Log in to reply