Nokia IP1220 installation / boot issues



  • Hi,

    I have a Nokia IP1220 on which I am trying to install pfsense v2.2 using the installed 40Gb HDD.

    I have used Win32DiskImager to 'burn' the ISO [live CD] to the HDD as the drive is IDE and the laptop I have is SATA :(

    I have set the HDD to the boot disk in IPSO boot manager:

    BOOTMGR[6]> printenv
    NOKIA IPSO BOOTMGR VERSION=4.1-BUILD016 05.19.2006-052320
    autoboot: YES
    testboot: NO
    bootwait: 3
    boot-file: /image/current/kernel
    boot-flags:
    boot-device: wd1
    vendor: Nokia
    model: IP
    bmslice: 4

    wd0 is the CF card
    wd1 is the HDD

    BOOTMGR[10]> boot
    /dev/wd1f on /mnt: Incorrect super block.
    Error: /image on /dev/wd1f
            does not exist or is not a file
    umount: /mnt: not currently mounted
    boot failed

    Does anyone have any idea's?


  • Netgate Administrator

    @h4rri:

    I have used Win32DiskImager to 'burn' the ISO [live CD] to the HDD

    You can't put a CD image onto a HD. Even if you did it would always be the live CD so it would forget it's settings at every boot. Not useful.  ;)

    How did you access the HD to put the image onto it?

    You can put the NanoBSD images onto a hard drive. It's not really designed for that but it will boot and run.

    Of course the ISPO boot manager may not boot anything but ISPO.  ;) Looks like it's trying to boot ' /image/current/kernel' which is presumably a Linux kernel and doesn't exist in pfSense.

    Edit: Do you know what CPU is in that, I'm having a hard time finding it?

    Steve



  • Hi,

    I used an IDE - USB adaptor. I will have to try and get a 2.5 - 3.5" IDE adaptor ti install it.

    I can tell BootMGR which file to boot.

    BOOTMGR[14]> sysinfo
    CPU 0: 1996 MHz Pentium 4/XEON
    Memory: 1073741824 (1024M bytes)
    Disk Devices:
            IO port 0x1f0 wdc0: unit 0 (wd0): <sti flash="" 7.2.0="">64MB (125440 sectors), 124 cyls, 16 heads, 63 S/T, 512 B/S
            IO port 0x1f0 wdc0: unit 1 (wd1): <fujitsu mhv2040as="">40007MB (78140160 sectors), 4864 cyls, 255 heads, 63 S/T, 512 B/S</fujitsu></sti>


  • Netgate Administrator

    Try putting the NanoBSD image onto it. That will at least prove it's capable of running. I was forgetting that IPSO is actually FreeBSD based so there's a good chance if it's not checking for signatures etc.

    Steve



  • IPSO is actually based on FreeBSD 7.x.  Back in the day, I created virtual machine images for IPSO testing by using a FreeBSD 7.1 LiveCD image to create the required partition layout for IPSO on a virtual disk using fdisk.  I then used dd to copy over the boot manager and the IPSO image to the correct locations.

    The image/current/kernel path is actually a symlink to the boot code on the disk.  Similar to how Linux works, when you upgrade IPSO, it will just update this symlink to point to the "current" boot image.

    At one time I had a set of written instructions for creating the partition layout, but I can't seem to lay my hands on it anymore.  I had fully functional IPSO virtual machines for IPSO versions 4.2 through 6.2.  Actually everything worked except ipsctl, since it wanted specific hardware in place.

    You should be able to totally dispense with the boot manager and just use a pure pfSense image.  However, you might run into NIC detection issues.

    Bill


  • Netgate Administrator

    Yes, the NICs in that particular box appear to have some form of acceleration on board from my brief research. They may just work as normal without whatever extras they have. Try it and see.  :)

    Steve



  • Tried the Nano install on the HDD and a flash card and it's not playing ball.

    I have a couple of spare DL380's so will use one of them instead, I wanted to use one of the Nokia's simply because of the better port density but that can't be helped.


  • Netgate Administrator

    Disappointing. Did it not boot at all? Did the image write to the drive OK? You extracted it from the gzip first?

    Steve



  • I haven't given up on the Nokia [too bloody minded] yet. I've ordered a 2.5" - 3.5" IDE adaptor so I can install of sense onto the HDD so I know it's working then I'll play with the bootmgr.

    I unzipped the gzip to be left with an ISO then 'wrote' that to the HDD / CF using Win32DiskImager


  • Netgate Administrator

    The Nano image is not an ISO it's a .img file.



  • Hey Guys.

    I am trying to install pfSense on an IP260 and am experiencing a variety of issues booting. Have you made any headway on this project at all? You ever get pfSense running on that IP Appliance? I would like to know so I can see if anything done here may/may not be helpful.



  • Hi h4rri,

    it is going, but Nokia was changing often during the entire production phase the platforms
    likes mainboard and cpu! So sometimes it is going on and sometimes not!

    pfsense Install on Nokia IP390 with success

    I get my Nokia IP560 next month, 16 x GB LAN Ports 1 x Aux 1 x RJ45 Console Port
    4 x 1 GB DDR2 RAM

    • Industrial CFCard 4 GB from Transcend
    • 2,5" IDE SSD 80 GB
    • Soekris vpn1411 if miniPCI slot is in

    I have a Nokia IP1220 on which I am trying to install pfsense v2.2

    Try another version under 2.2.1 perhaps an older version I mean!



  • Hi,

    The pfsense install works in the PC I installed the HDD in.

    The issue is getting IPSO to boot to the pfsense install :(

    Still plugging away though.



  • Dragging this up from the depths, to offer an update.

    I have been scouring the instructions for the IP and trying to fathom how to modify the boot loader of it.

    It transpires I have failed in the most basic way, when I opened the chassis the 'right way' I discovered the CF card holding the IPSO boot loader. As such I should be able to replace this with a CF card containing LILO / Grub.

    I have gleaned that a standard lilo contains:

    boot=/dev/hda
    map=/boot/map
    install=/boot/boot.b
    compact
    image=/boot/vmlinuz-2.0.36
        label=linux
        root=/dev/hda2
        read-only

    My issue is that I have no idea what partitions are used by default in the installation. I will boot the installation from the a PC tonight but if anyone can save me the cumbersome job by detailing the partitions that would be appreciated.


  • Netgate Administrator

    I bit late replying here!
    If it has a CF card slot the first thing to try is just writing a Nano image to the CF card and boot that. Make sure you use the correct image, probably no VGA port on that so don't use the Nano+VGA image.

    Steve



  • Hi everyone!

    I'm also interested of getting pfSense to run in IP1220.

    I have had a lot of problems with my current firewall. I'm running pfSense in an old Intel based computer, which is equipped with 500 MHz Pentium. This is kind of slow hardware for running pfSense and VPN's.

    Today I dug out the old Nokia IP1220. If this old hardware is capable of running pfSense, this would be the best solution for to be  my next firewall.
    Therefore I would be glad to get any possible information of this matter.
    I don't have any of the HDD:s, there's only two empty slots. I also have no idea, if there is suitable drivers in pfSense for the LAN cardrs.

    All I know, there's a CF card installed in the mainboard. This is my only option for installing the pfSense.



  • You can run an instance from the CF card, I wanted to use the HDD's [they are normal 2.5" IDE drives] so this is the cause of the extra issues I am experiencing.


  • Netgate Administrator

    Write a Nano image to a CF card and boot it see what happens.
    I imagine this is 32bit so try this: http://files.atx.pfsense.org/mirror/downloads/pfSense-2.2.6-RELEASE-1g-i386-nanobsd.img.gz

    Extract and write it as described here: https://doc.pfsense.org/index.php/Writing_Disk_Images

    Check the serial console.

    Steve



  • At first, everything looked fine. I could see the boot started up fine.
    Then suddenly the following came up:

    "panic: atpic_assign_cpu: bad cookie pfsense"

    I tried to find a solution for this, but coldn't find any.  I tried different CF card, and I couldn't repeat this "panic". However, I could see the same result with the different CF card.
    Befor the panic, there is repetitively going the following lines:

    (ada0:ata0:0:0:0): Error 5, Retries exhausted
    (ada0:ata0:0:0:0): READ_DMA. ACB: c8 00 df 0d 1e 40 00 00 00 00 01 00
    (ada0:ata0:0:0:0): CAM status: Command timeout
    (ada0:ata0:0:0:0): Retrying command
    (ada0:ata0:0:0:0): READ_DMA. ACB: c8 00 df 0d 1e 40 00 00 00 00 01 00

    It looks like the DMA transfer is broken etc.

    Then I found an old 1 GB CF-card, which was installed in an old WatchGuard Firebox II. This has some old version of pfSense (perhaps 2.2.2 )
    This CF booted ok. I could see all the network interface cards, and I could see they were working.
    Wen I got the system working, I did the automatic upgrade from the web configuration page (Invoke auto update).

    After this the boot failed again witht the same problem as earlier.

    So, I begin to think, if there is some kind of workaround or solution for this. I wouldn't want to use any old version, if newer is available with some tweaking etc.
    I just don't have any glue on how to proceed with this…



  • I can not boot the pfSense.
    I have went through the "Boot issues" documentation and tried to find a solution with my friend Google. However, I'm stuck in booting.
    The pfSense version 2.1.5 is the last version which works and boots fine. When installing newer version, the boot fails.

    I have tried to disable the DMA, cachec etc. which was decripted in "Boot issues" documentation. However, none of these helped me solve the problem.
    This is really frustrating, since I know the hardware works fine, the hardware is quite powerfull, but can only be used as a firewall.

    Is there any workaround? Any way to alter the booting mechanism?

    I also have two IDE slots, but the connector looks weird. I don't know where to find suitable disk or disk tray for this.

    I would be so glad to get some solution for this!