2.2 Upgrade - DHCP no longer working for bridged WLAN



  • I have the LAN and WLAN bridged because I never got DHCP and DNS forwarding working when I have them on different subnets. Consequently, DHCP on WLAN is disabled. This used to work fine for many years. Since recently, and possibly since I upgraded to pfSense 2.2 earlier today, WLAN clients no longer get DHCP addresses assigned. Clients with static settings work fine.
    When I enable DHCP on WLAN, clients get an IP address but for the WLAN subnet that is "hidden" because WLAN is bridged, and their DNS and gateway addresses don't work.
    Is this no longer a supported configuration?

    I uploaded the redacted configuration file.
    config-firewall-20150206222559.txt


  • Banned

    No idea what you are doing with the bridge and interfaces, post your configuration. Also no idea what you mean by "I never got DHCP and DNS forwarding working". Can assure you that DNS and DHCP works just fine on non-bridged WLAN. So does DHCP relay if you don't run DHCP on pfSense.

    (If there's some wiki article regarding this "bridging" I suspect it'd strongly benefit from pressing a delete button – second thread today about some whacky LAN-WLAN bridge broken.)



  • Also, maybe unrelated, but the CPU runs at 100% pretty much all the time. I have no packages installed and the only services running are dhcpd and the DNS Forwarder (Netgate M1n1wall). When I disable the WAN interface, CPU utilization goes down to normal. This is with just a laptop connected on the LAN port for diagnostics.

    last pid: 98648;  load averages:  2.71,  3.03,  3.01  up 0+08:28:49    22:16:59
    100 processes: 4 running, 83 sleeping, 13 waiting
    
    Mem: 18M Active, 50M Inact, 72M Wired, 28M Buf, 78M Free
    Swap: 
    
      PID USERNAME PRI NICE   SIZE    RES STATE    TIME    WCPU COMMAND
    30699 root      84    0 15092K  8372K RUN    217:05  38.96% /usr/local/sbin/ipfw-classifyd -n 8 -q 700 -c
    96339 root      52    0 35480K 21584K piperd   0:05  21.78% php-fpm: pool lighty (php-fpm)
       12 root     -72    -     0K   104K WAIT    53:52  14.79% [intr{swi1: netisr 0}]
    30699 root      27    0 15092K  8372K sbwait  74:25  13.28% /usr/local/sbin/ipfw-classifyd -n 8 -q 700 -c
       15 root     -16    -     0K     8K -       32:47   8.06% [rand_harvestq]
       11 root     155 ki31     0K     8K RUN     58:58   0.00% [idle]
       12 root     -56    -     0K   104K WAIT     3:40   0.00% [intr{swi5: fast taskq}]
        0 root     -16    0     0K    88K swapin   1:02   0.00% [kernel{swapper}]
       12 root     -60    -     0K   104K WAIT     0:56   0.00% [intr{swi4: clock}]
       12 root     -92    -     0K   104K WAIT     0:31   0.00% [intr{irq9: ath0}]
    53560 root      20    0 10300K  2056K select   0:28   0.00% /usr/sbin/syslogd -s -c -c -l /var/dhcpd/var/
        5 root     -16    -     0K     8K pftm     0:25   0.00% [pf purge]
        0 root     -92    0     0K    88K -        0:25   0.00% [kernel{ath0 taskq}]
       54 root      -8    -     0K     8K mdwait   0:13   0.00% [md1]
    27287 root      20    0 10364K  2092K bpf      0:11   0.00% /usr/local/sbin/filterlog -i pflog0 -p /var/r
    36372 root      20    0 13148K  5664K kqread   0:08   0.00% /usr/local/sbin/lighttpd -f /var/etc/lighty-w
    30699 root      20    0 15092K  8372K kqread   0:06   0.00% /usr/local/sbin/ipfw-classifyd -n 8 -q 700 -c
      285 root      20    0 31384K 16108K kqread   0:04   0.00% php-fpm: master process (/usr/local/lib/php-f
    
    


  • The answer to the CPU load problem was here https://forum.pfsense.org/index.php?topic=87513.0. I disabled layer 7 shaping and, after a reboot, the CPU is back to normal and there are no more "ipfw-classifyd: packet dropped: output queue full" messages in the log.

    And after a few more tests with various other devices I can confirm that disabling Layer 7 traffic shaping also resolved the DHCP issue - all my wireless clients appear to work fine again.


Log in to reply