DHCP not reacquired after modem restart (UK Virgin media)

  • I'm running pfsense 2.2 and recently had some issues with my Virgin Media broadband service dropping.
    The last two-three weeks now at about the same time on a Friday evening my Virgin modem (in modem mode) performs what looks like a reset, this is the error I found in the modems log.

    Received Response to Broadcast Maintenance Request, But no Unicast Maintenance opportunities received - T4 time out

    DuckDuckGo'ing I found a T4 error is

    Explanation: The cable modem did not received a station maintenance opportunity in which to transmit a Ranging Request (RNG-REQ) message within the T4 timeout period (30 to 35 seconds). The cable modem is resetting its cable interface and restarting the registration process. Typically, this indicates an occasional, temporary loss of service, but if the problem persists, check for possible service outages or maintenance activity on this particular headend system. This error message is DOCSIS event message is R04.0, Ranging Request.

    Once the line comes back up and the modem resents as indicated by a light on the front, the DHCP address for my WAN interface stays down. Checking the log I see I pretty much continuous stream of dhclient: DHCPDISCOVER on igb4 (<my wan="" nic)="" to="""" interval="" x="" (x="1">17 or so)…I don't have the actual log entries to reference but basically it looks like either the modem is refusing to hand out a DHCP or pfsense can't allocate/assign one.

    I've fiddled (uneducated random experimentation) with the DHCP request settings in the interface settings but been unable to get the pfsense box to bring the line back up without both resetting the modem and rebooting pfsense.

    Any ideas how to coerce/force pfsense to reacquire the IP address without manually prodding it?</my>

  • I'm having the same problem on 2.1.5.  Only way I can get the WAN Interface back up is to manually restart the interface. Would be nice if there was an automatic way for pfSense to monitor the interface and restart it if down.

  • So it happened again this evening, I guess Virgin use 7 day leases.
    Gateway goes down, dhcp broadcasts for an address and one isn't found.
    Eventually tries cached one which doesn't get accepted by the gateway as no traffic flows between the superhub and pfsense. FML! Can't figure out how to get these to re sync. Tried static IP, tried disabling gateway monitoring but not joy.

Log in to reply