Squid 3.4.10_2 Error On PfSense 2.2-RELEASE



  • After upgrading to 2.2-RELEASE, squid would not start. System details and system logs are below. Any help would be greatly appreciated:

    1. pfSense details:

    2.2-RELEASE (i386)
    built on Thu Jan 22 14:04:25 CST 2015
    FreeBSD 10.1-RELEASE-p4

    2. Squid3 details:

    3.4.10_2 pkg 0.2.6

    3. System Logs after a re-installation:

    php-fpm[29132]: /pkg_mgr_install.php: The command '/usr/pbi/squid-i386/sbin/squid -z -f /usr/pbi/squid-i386/local/etc/squid/squid.conf' returned exit code '1', the output was '/usr/pbi/squid-i386/local/sbin/squid: Undefined symbol "_ZN7libecap4NameC1ERKNSt3__112basic_stringIcNS1_11char_traitsIcEENS1_9allocatorIcEEEEi"'

    4. /etc/libmap.conf contents:

    includedir /usr/local/etc/libmap.d
    libstdc++.so.6  gcc46/libstdc++.so.6



  • I just came here yesterday for some questions about squid/squid3, but it would seem that there is no i386 binaries for squid3 on pfSense2.2 yet. Relevant persons has been pinged about the issue and its expected to be included soon. I think you have to compile it yourself atm.



  • squid pbi is broken for i386 as you can find in many threads like this.

    Search the forum to find a way to get it working, upgrade to amd64 if your hardware support it and maybe test squid i386 again when 3.4.11 pbi get available on pfsense repo.



  • pbi were rebuild, check if transparent proxy on i386 is fine now

    squid-3.4.10_2-amd64.pbi  09-Feb-2015 17:22
    squid-3.4.10_2-i386.pbi  09-Feb-2015 17:41



  • Not working. Still the same error.



  • Did you uninstalled and reinstaled the package?



  • Yes. Re-installed many times. Tried a restart. Still the same error as seen here:

    Feb 15 13:33:45 php-fpm[94349]: /pkg_mgr_install.php: The command '/usr/pbi/squid-i386/sbin/squid -f /usr/pbi/squid-i386/local/etc/squid/squid.conf' returned exit code '1', the output was '/usr/pbi/squid-i386/local/sbin/squid: Undefined symbol "_ZN7libecap4NameC1ERKNSt3__112basic_stringIcNS1_11char_traitsIcEENS1_9allocatorIcEEEEi"'