Pfsense cannot auto-negotiate network connection speed/duplex



  • I am having a major nightmare getting my alix board to negotiate a link between 2 different ISPs - it wont auto-nogotiate either of them, and I am not sure how to correctly specify the <media>setting.

    I have had success with the Alix on other ISPs, and it will even auto mdix on other connections. But not these 2, one is a T1 coming through an Adtran CSU, the other is a land based satellite provider Skyriver who uses some sort of white box access point - both are connected to my ethernet connections on the Alix, and have tried swapping all the cables, both give a link light, but in the gui it says "no carrier" and Media "none" - both use static IPs, and I have asked the ISPs to set various speed negotiations with no success.

    heres my wan config:
    <wan><if>vr1</if>
    <mtu><blockpriv><media><mediaopt><bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype>
    <spoofmac><blockbogons><disableftpproxy><ipaddr>74.9.x.x</ipaddr>
    <subnet>29</subnet>
    <gateway>74.9.x.x</gateway></disableftpproxy></blockbogons></spoofmac></mediaopt></media></blockpriv></mtu></wan></media>



  • Have a look at http://doc.m0n0.ch/handbook-single/#FAQ.hiddenopts for how to find out the correct mediaoptions. You can run the commands at diagnostics>command from the webgui or from the shell.



  • I understand the option is <media></media>and looked at that site, but it does not describe what parameters are available under that option.



  • "Refer to the appropriate FreeBSD manpage for the driver you're using to see which options are available (or run ifconfig -m)."


Locked