New PfSense build and results



  • After my Linksys router started to give me problems, reboot every day I, decided to build a PfSense box.

    Hardware:
    Gigabyte GA-H97N-WIFI – don’t need the WIFI and the Intel 7260HMW is not supported in FreeBSD
    Intel Celeron G1820 processor
    Corsair Memory of 4 GB
    SanDisk 64Gb SSD
    SilverStone Milo5 case
    SilverStone SST-ST030SF 300 watt power supply

    I bought the motherboard because it had two LAN NICs and every thing was on sale and/or had rebates at MicroCenter.
    After installing ver 2.1 with a USB drive I found that only the Intel Pro/1000 was recognized. The other NIC is an Atheros AR8161 which is not supported with FreeBSD ver 9.x and 10.x. I looked at the FreeBSD site and found that the adapter is supported in ver 11.0-CURRENT. I downloaded the 64 bit ISO file and burned a CD. On the CD in the directory /boot/kernel I found the file if_alc.ko and searched the contents for the AR8161 and found a reference to it. I looked in the file and found a referenc to AR8161 so I decided to try it. I copied it to a USB drive. On the PfSense box I created a mount point and added an entry in /etc/fstab. I then copied the file to /boot/kernel on the PfSense box. I also added the following in the /boot/loader.conf,```
    if_alc_load=”YES"

    
    I have since upgraded to PfSense version 2.2-RELEASE.
    
    One problem that I had was getting to the outside. After I saw something on the forum I added 127.0.0.1 to the list of the DNS servers and everything worked. **Why was this needed?**
    
    To date it has been running for 8 days without any problems. The system is very quiet and cool. I have not seen the power supply fan turn on and the temperature of the CPU is 27.80 C.
    
    I have installed the port PfBlocker for Asia and in 4 days it had over 13,000 hits. I have a lot of fine tuning to do yet.
    
    ![DSC05714 (Small).JPG](/public/_imported_attachments_/1/DSC05714 (Small).JPG)
    ![DSC05706 (Small).JPG](/public/_imported_attachments_/1/DSC05706 (Small).JPG)
    ![DSC05714 (Small).JPG_thumb](/public/_imported_attachments_/1/DSC05714 (Small).JPG_thumb)
    ![DSC05706 (Small).JPG_thumb](/public/_imported_attachments_/1/DSC05706 (Small).JPG_thumb)


  • better add it to /boot/loader.conf.local (if it doesn't exist, create it).

    the regular loader.conf can/will be overwritten when you perform an update ; the .local will stay there permanently
    you could probably put in a feature request on https://redmine.pfsense.org to make the driver available in one of the next releases.

    good work



  • Heper,

    It is /boot/loader.conf.local. Sorry, my bad!

    Here is the man page for ver 11.0
    https://www.freebsd.org/cgi/man.cgi?query=alc&apropos=0&sektion=4&manpath=FreeBSD+11-current&format=html

    Here is the release notes
    https://www.freebsd.org/relnotes/CURRENT/relnotes/article.html#drivers-network
    http://svnweb.freebsd.org/base?view=revision&revision=272730

    I shall take a look and see what it takes to request a change.

    I have two servers running FreeBSD 9.3-RELEASE and have been using FreeBSD since ver 5.0. We always had problems with Microsoft Windows Server but the only time FreeBSD had problems if we had hardware issues and the same was for HPUX.

    Thanks!



  • Nice build! Wish a had a more low-profile case like yours.

    I was just searching online for builds to see what others did. I seemed to see a lot of cases of people using Intel Atoms, but glad to see I'm not the only one that went the Celeron route  8)

    Here's my build, for anyone else interested in pfSense box build ideas - https://docs.google.com/spreadsheets/d/1PpNFI2ZOqWHlWzHfASq_lyYmyTVF6Yj7hextTX_toT8/

    NOTE: Initially I only had the 1 Intel PCIe NIC for LAN (use the mobo's onboard NIC for WAN, worked out of box), but I added the TP-LINK NIC for DMZ. Don't actually have the wireless NIC but my research indicates that it should work out of box as well.



  • Hey I followed your guide on a "GIGABYTE GA-Z97N-WIFI" it has the same 2nd NIC "Atheros 8161B". But I was unsuccessful.
    is there any steps other than copying the file "if_alc.ko" and editing "/boot/loader.conf.local"?

    Thanks



  • I just bought motherboard "GIGABYTE GA-Z97N-WIFI" and having a problem with pfsense 2.2.4 not recognizing LAN2 NIC (Atheros 8161B).

    pfsense 2.2.4
    It is based on FreeBSD 10.1 - which includes Atheros support but for only Atheros AR813x/AR815x NICs (link: https://www.freebsd.org/cgi/man.cgi?query=alc&apropos=0&sektion=4&manpath=FreeBSD+10.1-RELEASE&arch=default&format=html)

    For this motherboard NIC2 to work, we need FreeBSD 10.2 or higher.  FreeBSD 10.2 supports (Atheros AR813x/AR815x/AR816x/AR817x) link: https://www.freebsd.org/cgi/man.cgi?query=alc&apropos=0&sektion=4&manpath=FreeBSD+10.2-RELEASE&arch=default&format=html)

    I do not want to install nightly experimental builds, so I will try to install if_alc.ko and load into the 10.1 kernel.


Log in to reply