IPSEC Passthrough Not Working



  • OK, I have tried smoothwall and ipsec passthrough did not work with that. Tried ipcop and still a no go. Tried pfsense and out of the box it worked…...... till I installed the squid package.

    What I have:

    / <network><comcast modem="">- <pfsense>-
                                                    \ <juniper ssg="">I need ipsec passthrough to work for the juniper as that is for me to connect to work.

    I did read in some other posts about forwarding esp, ahand gre. I have them forwarded on the ipsec, lan & wan interfaces. I also have it checked to allow ipsec passthrough.

    I really don't want to uninstall squid to get this working as it should be able to pass the traffic.

    Any ideas will be welcome.</juniper></pfsense></comcast></network>



  • I don't see how squid could interfere with that. It doesn't listen on the ports or protocols used by vpn. Btw, GRE is only for PPTP and you won't need it for IPSEC. Are you running squid in transparent mode?



  • yes, I am running squid in transparent mode.



  • Can you try and see if it works again if squid is in non transparent mode?



  • tried it and still not working. I have reset pfsense back to factory defaults and still will not work. I am thinking about reinstalling to see if that will work.



  • ok… reinstalled.. working.
    installed squid.... working.
    installed imspector... working.

    dont know why but it is working. thanks to everyone for the help.


Log in to reply