Squidguard time schedule does not run properly



  • Dear all…......
    Pfsense-v2.1.5 with a non transparent squid3-dev + SquidGuard3 + wpad.
    In SquidGuard are the settings time:
    07: 00 - 08: 00
    11: 45 - 13: 15
    17: 00 - 21: 00
    to open the category of social media and video.
    Pfsense does not operate 24 hours a day, I usually turn on at 08:00 and off at 21:30.
    The problem is why the the settings does not go according to the rules, so when the time shows 11:45, social media and video category remains blocked.
    Running again if I press save and apply button in the main tab of SquidGuard
    So I have to always save and apply SquidGuard every at on-time and off-time crossing.
    How to resolve this, please enlightenment..........
    Sorry for my bad english



  • I have schedules working with SquidGuard to open several categories at lunchtime and it seems to work for me.  Are you sure it isn't the browser caching the block page?



  • Thanks for the response…

    I'll check tomorrow...

    But what if I press the Apply button on SquidGuard, timing immediately run without cleaning cache in the browser



  • In some cases you will need to schedule a squid -k reconfigure after lunch time.



  • Dear marcelloc…

    Does it use cron service to /usr/local/sbin/squid ?
    Is this a bug ?
    Is this also happens in version 2.2 ?......, because last I tried version 2.2, squidguard3 not work .... although squid3 function properly.

    Thank you in advance



  • Dear all….......

    Based on the guidelines of marceloc (thanks bro .....)

    0    7    *  *  *      root sleep 30; /usr/local/sbin/squid -k reconfigure
    0    8    *  *  *      root sleep 30; /usr/local/sbin/squid -k reconfigure
    45  11  *  *  *      root sleep 30; /usr/local/sbin/squid -k reconfigure
    15  13  *  *  *      root sleep 30; /usr/local/sbin/squid -k reconfigure
    0    17  *  *  *      root sleep 30; /usr/local/sbin/squid -k reconfigure
    0    21  *  *  *      root sleep 30; /usr/local/sbin/squid -k reconfigure

    This at least be a first aid, prior to a better solution.
    Finally, if this is also happening in v2.2, because the last time I tried, squidguard3 not functioning, although squid3 running smoothly.

    Everyone, thank you for help



  • Dear PfSense developers,

    This problem is become chronic! "Squidguard time schedule does not run healtly"  :'(  :'(  :'(

    Please, help us.