Enabling squid proxy slows down speedtest.net speed test



  • Just setup my pfsense box today, so be kind :)

    With my computer connected directly to ISP router (actiontec) I get:

    With my computer connected to the pfsense box (Dell Poweredge 2650 with dual 1.8 Ghz Xeons, 400 FSB, 512k L2, 1 GB system RAM, 2x18 GB 7200 RPM U160 hard drives in RAID 1 connected on onboard raid controller with 128 MB raid controller memory) I get the same as above.

    However, if I enable the squid package addon, the speedtest.net test is reporting only:

    I set the squid package to use 512 MB memory cache size under cache management.

    Any ideas on how I could improve this as I would like to run squid to reduce unneeded bandwidth use and provide a little extra performance boost, but it seems I'm creating the opposite effect :(



  • If you have a look you'll find a couple of long threads on this subject.  People's experiences vary, some reporting major slowdowns, others (like me) having no such problem.  It will at least give you a place to start from.





  • Try 1.2 RC3 and let us know your results.

    http://pfsense.loquefaltaba.com/downloads/old/



  • I wonder if this is kernel raleted. We had some odd reports that the uniprocessorkernel sometimes causes various issues/glitches on  uniprocessor machines. If you have the option to test please retest with the smp-kernel even if you have a uniprocessor machine and report back.



  • I have tried on both uniprocessor and dual processor machines and tried both the SMP and uniprocessor kernel on my dual proc machine.  Same results.  If I roll back to 1.2 rc3 all is well.



  • @hoba:

    I wonder if this is kernel raleted. We had some odd reports that the uniprocessorkernel sometimes causes various issues/glitches on  uniprocessor machines. If you have the option to test please retest with the smp-kernel even if you have a uniprocessor machine and report back.

    Thanks, but I'm running on a dual 1.8 Ghz Xeon and am running the smp-kernel already.

    FreeBSD islandred 6.2-RELEASE-p11 FreeBSD 6.2-RELEASE-p11 #0: Sun Feb 24 16:49:14 EST 2008    sullrich{at)builder6.pfsense



  • To Fix Squid

    add this to the /boot/loader.conf

    kern.ipc.nmbclusters=32768
    kern.maxfiles=65536
    kern.maxfilesperproc=32768
    net.inet.ip.portrange.last=65535

    or just delete it and replace with

    autoboot_delay="1"
    #kern.ipc.nmbclusters="0"
    hint.apic.0.disabled=1
    kern.hz=100
    #for squid
    kern.ipc.nmbclusters="32768"
    kern.maxfiles="65536"
    kern.maxfilesperproc="32768"
    net.inet.ip.portrange.last="65535"

    you might ask why squid is so slow? its because default configuration of pfsense is router not as a server
    thats why kern.ipc.nmbclusters="0" <- is set to zero. if you just simply remove this squid will be just fine.

    but to tune the squid i add this
    kern.ipc.nmbclusters: 32768
    kern.maxfiles=65536
    kern.maxfilesperproc=32768
    net.inet.ip.portrange.last: 65535

    i just figure out why squid is slow. but i don't like the binary package of squid. i'll be using the squid HEAD bec of the store_rewrite feature for caching youtubes videos and other video files and mp3.


Log in to reply