Error enabling cachemgr with squid



  • Hi,

    I am trying to enable cachemgr on squid following the guidelines in https://forum.pfsense.org/index.php?topic=14609.0

    However I cannot find a directory named squid in '/usr/local/etc/'

    I have tried re-installing squid. Stopping and starting the service, but it did not help.

    Could someone please help me on this?

    I am on the latest version of pfsense
    "2.2-RELEASE (amd64)
    built on Thu Jan 22 14:03:54 CST 2015
    FreeBSD 10.1-RELEASE-p4"

    and the squid package version is 2.7.9 pkg v.4.3.6

    Many Thanks for your help.





  • Thanks newbie,but it is the same setup that I was following.

    There is a line to execute 'cd /usr/local/etc/squid'
    My issue is, I don't have the above folder in my pfsense box.



  • You're trying to follow a 6yo guide for something that has changed a lot since.  I don't know how ot fix this under 2.2 but if I need ot look at some cache stats, I just shell in and run

    squidclient -p 3128 mgr:info

    There isn't even a cachemgr.cgi in the /usr/local/www folder.  Copying it in from /usr/pbi/bin/libexec/squid and running it results in a 500 Server Error.



  • Thanks for your reply KOM. I will check this ones Im in the office.

    Is there any mechanism in the forum to mark these obsolete methods as obsolete?

    Many Thanks for taking the time to reply.



  • Thanks again KOM. When I tried the commandsquidclient -p 3128 mgr:infoI got timeout errors, but could be easily fixed by including the server IP address (I used loopback address).```
    squidclient -p 3128 -h 127.0.0.1  mgr:info