[SOLVED]:4 minute wait at 'Configuring firewall' after upgrade from 2.1.5 to 2.2



  • I recently upgraded a Soekris Net5501-70 system that was running 2.1.5 to 2.2.  After the upgrade, I'm experiencing much longer boot times due to boot-up hanging at the first "Configuring firewall".  Boot eventually does complete, but that particular spot takes 4 minutes when booting 2.2 compared to only 20 seconds when booting to 2.1.5.

    My setup is relatively simple.  One WAN, one LAN, and one OPT interface (which is one end of a Metro-E line).  I have OpenVPN configured, and that's about the extent of it.  Nothing too complex.  I'm just curious as to how I can go about determining why it takes 11 times longer on 2.2 than 2.1.5.

    UPDATE:  I had PFblockerNG installed and its timeouts were causing the issue.  Following the 'fix' in this thread (as suggested by BBcan177) did the trick:
    https://forum.pfsense.org/index.php?topic=88776.0


  • Moderator

    Do you have pfBlockerNG installed, if so, please follow the fix. In this thread.

    https://forum.pfsense.org/index.php?topic=88776.0



  • Thanks BBcan177, looks like that was the issue.  Following the fix in the thread you linked fixed it.