Pfsense 2.2 squidguard don't block - Solved by work around



  • Hi, i've installed squid3 and squidguard. Squid seems to be fine but squidguard is not blocking. I've added shalla black list, added best test category which is "porn" (set at common ACL to deny) target rules shows blk_BL_porn. And nothing still can visit porn sites.



  • Are squidguard service running well sir?  :)



  • Squidguard is not working in 2.2, please try to use it in the previous version



  • Previus version of squidguard or pfsense ?



  • pfsense



  • It seems to work fine for me.  I'm thinking there is a problem with your rules, like a corrupted download or something.



  • KOM it's a clean install. No rules. Is there other way to block from blacklists ?



  • Nevermind the blacklists for now.  See if you can get it working by creating a Target Category, fill it with a test domain and then link it into the Common ACL and see if it blocks.  Are you trying to block HTTPS sites?  Do you have Squid in transparent or standard mode?



  • Thx KOM, expresions in target category works fine. I hope they wil fix blacklists soon.
    But a cant add unrestricted IP this option doesn't work :/ when i uncheck "allow users" squidguard can't start …. something is messed up



  • The blacklists work fine.  I think you might be doing something wrong or something is misconfigured.

    Is this on pfSense 2.1.5 or 2.2?



  • 2.2



  • I guess it would have helped if I read the title again  :P

    I just posted a report about a glitch when installing SquidGuard after JimP updated it the other day.  SquidGuard is working if you can create your own target category, add a domain or regex and then use it to successfully block that domain.

    Can you please explain what you mean by this:

    But a cant add unrestricted IP this option doesn't work :/ when i uncheck "allow users" squidguard can't start



  • I want to exclude one IP (admin pc) from proxy filtering. Now proxy is set to transparent.
    So I added IP to Unrestricted field and nothing happen …



  • So I added IP to Unrestricted field and nothing happen …

    By 'nothing happens', you mean that the admin user is still being blocked from some domains?  BTW I used to use Transparent mode but I found that it was a major hassle trying to filter HTTPS, so I switched to non-Transparent mode with WPAD.  So much better, everything works and easier to control to do what you want.