AHCI time out cannot install



  • Hi

    I have a few Biostar TF720 A2+ (nvidia nforce 720a chipset) main boards that I want to install pfSense 2.2 x64 onto. However, no matter what HDD I use and board etc. The installer does not see the HDDs. This is apparently some bug with AHCI on FreeBSd 10.1? Or BIOS issue?  It actually doesn't matter if the BIOS is set to SATA mode or AHCI the same errors occur: a CAM error and timeout with no drives being detected. Eventually the installer continues, but the errors persist:

    ada0:ahcichX:0:0:0): CAM status: Command timeout Where X is the port (I tried different ones).

    I also have the same problem on an Intel entry server board with a P4 using the i386 version. In this case it is a GEOM mirror, but the CAM error occurs. I have tried 9 different configurations with 7 different HDD. Googling tells me all 7 drives are bad, this just can't be as the drives work fine with Untangle NG (trying to dump using that and use pfSense instead). I do not want to go down in history stating that pfSense installer can't deal with SATA drives, right? 14 hours later any help IS completely appreciated.  :'(



  • Is there a bios update available?  Have  you tried resetting to 'bios defaults'?
    Are the drives detected correctly by the bios when booting (before any OS starts)?
    Are the drives detected when booting a FreeBSD 10.1 live CD?  A linux live CD?

    Is the same case and power supply when you tried the other MB?  If so, maybe check your PS voltages.

    If all that is OK, then there are some tunables that can be set for ahci(4):
    https://www.freebsd.org/cgi/man.cgi?query=ahci&sektion=4



  • Hi thanks for quick response!  ;D I am booted on the machine now with parted magic and ran smart diagnostics on current disk. It is OK. I will get a FreeBSD 10.1 Live CD and give it a whirl! All other things were tried. What I am freaking on is the i386 CD on the Intel board also had the same errors. Different box altogether. Anyway, thanks again.



  • I had the same problem, could not get it to install.

    In the bios I switch it from AHCI to IDE (even tho its a SATA drive) and pfSense installs with no errors.



  • [SOLVED]
    Hey All thanks for your replies. Really appreciate the interest level on these boards! FWIW, I am an old timer. I was using FreeBSD in 1993 when the AT&T lawsuit started and then started with Slackware 1 from Linux Systems labs, I still have the 20+ floppies it came on. pfSense is awesome. Far more flexible (and more complicated) than Untangle and I am grateful for it.

    I exaggerated on 7 drives in my original post it was 5. All were used drives. I upgraded the BIOS and it got farther along but still had the CAM timeout error. There is no IDE emulation in the BIOS of these boards, only SATA or AHCI. I tried a FreeBSD Live CD and had the same errors. What I learned is that FreeBSD 10.x is rigorous in its examination of the drives and apparently queries SMART status? No time to confirm. These drives work fine on Windows and Linux but the FreeBSD installer is tough and RIGHTFULLY so.

    I put in a different used drive (#6 - an Hitachi! can you believe it?!) and the problem went away. After the fact I booted partedmagic and used the SMART utility and all of the drives had pre-failure warnings where the Hitachi didn't. After a fair amount of googling some have had problems with new drives too. I can't account for that. However, it is clear to me that FreeBSD 10.x will not install on drives with SMART pre-failure warnings. Thanks thanks thanks.

    Off to my new post about IPSec firewall rules and pfSense 2.2 . . . going to try 100 configs before posting. If I get it right, I will post my results because as I said; old timer and I appreciate the boards.  :D



  • Hello Guyz,

    I am new in pfsense i was trying to install pfsense 2.3.5 from usb on dell optiplex 755 with 500gb hdd , 4 gb ram with  but i am facing
    AHCI time out cannot install…

    can you help me how to resolve this or this hardware is supported .


Log in to reply