Arp is not displaying any hostnames



  • I have configured the static entires correctly under DHCP server so MAC address correlate to an IP address …. however when I go to Diagnostics>>ARP Table - it shows only the IP address, the MAC Address, and Interface.

    I am unable to ping anything on my local network via hostname, for example if I run the command 'ping chromecast' it times out, but if I ping 192.168.1.202 it will ping.

    Any Ideas, I attached a screenshot as well.

    My DNS settings in "General" are 192.168.1.1, 8.8.8.8, and 8.8.4.4 - I can't think of anything else that would cause this.



  • Bug #1: Names containing "_" (underscore) are not being displayed. The code that reverse-resolves IP addresses to names then pattern-matches the names to try and find the valid host/domain name, but the pattern match was missing the underscore as a valid character.
    This is fixed by: https://github.com/pfsense/pfsense/pull/1497

    See if that helps you - maybe your names have underscores in them?

    Bug #2: When DNS Forwarder "Do not forward private reverse lookups" is checked, the system is not forwarding reverse resolve requests to domain override entries. "Do not forward private reverse lookups" is supposed to just stop general referrals of private reverse lookups to the default upstream name servers - i.e. we do not want to send rubbish like that to the public internet DNS. Entries for private reverse lookup domains in Domain Overrides are supposed to still work. I know that worked OK back in 2.1.? when I coded it. I will look and see what is wrong in 2.2.

    If I unchecked "Do not forward private reverse lookups" then I get host names for all my ARP/IP entries that do actually have reverse lookups available somewhere.

    Edit: I forgot that there is a bonus "feature" in that "Do not forward private reverse lookups". If you have a domain override like:

    10.in-addr.arpa
    

    that matches exactly a whole block of the IPv4 private address space. The underlying code is blocking reverse lookups for exactly that whole 10.in-addr.arpa
    You can only Domain Override individual parts of that, e.g.

    40.10.in-addr.arpa
    41.10.in-addr.arpa
    42.10.in-addr.arpa
    
    

    I should make the code smarter to look and see if there is a domain override that matches exactly the whole block of private IPv4 address space, then do not put in a block of that same space.

    Edit again: I made the code smarter - https://github.com/pfsense/pfsense/pull/1498
    This will also help some other people who had domain overrides for reverse lookup private IP address space that were not effective.



  • How do I apply the patches? Sorry I'm moderately new to modems I'm trying to migrate from commercially made to open source do it yourself.

    Any help is appreciated, thanks.



  • Nevermind figured it out i needed to enable  Register DHCP leases in DNS forwarder and  Register DHCP static mappings in DNS forwarder to get it working.



  • @voncloft:

    How do I apply the patches? Sorry I'm moderately new to modems I'm trying to migrate from commercially made to open source do it yourself.

    Any help is appreciated, thanks.

    To apply patches you can install the System Patches package and that lets you apply patches from Github or other sources in a controlled manner.

    It seems the 2 bugs that I noticed were not ones that particularly effected you. If you do not use underscore in host names, and do not have the special reverse lookup domain overrides then you would not notice either of those.