Can't clear PfTop Label statistics - 2.2R(64)



  • Noticed after 2.2 upgrade PfTop/Label appears to be misreporting.  Any rule that hasn't been hit doesn't begin at zero pkts/bytes.  Below is a snip of it showing the email ports not hit all showing 46 pkts & BitTorrent with 6939 pkts.  Tried pfctl -F info and pf reported "statistics cleared" but didn't correct this issue.  Neither does a reboot.

    Anyone experience this?  I've noticed a few other oddities so I'm trying to sort them out as either a known issue or just my issue.

    RULE LABEL              PKTS  BYTES STATES  MAX ACTIO DIR LOG Q IF    PR    K
    181 USER_RULE: Email      46  2764      *      12    Out      igb0  tcp   
    182 USER_RULE: Email      46  2764      *      12    Out      igb0  tcp   
    183 USER_RULE: Email      50  2996      *      12    Out      igb0  tcp   
    184 USER_RULE: Email      60  3620      *      12    Out      igb0  tcp   
    185 USER_RULE: Email      46  2764      *      12    Out      igb0  tcp   
    186 USER_RULE: Email      46  2764      *      12    Out      igb0  tcp   
    187 USER_RULE: Email      46  2764      *      12    Out      igb0  tcp   
    188 USER_RULE: Email    388  23880      *      12    Out      igb0  tcp   
    189 USER_RULE: Email      46  2764      *      12    Out      igb0  tcp   
    190 USER_RULE: Email      46  2764      *      12    Out      igb0  tcp   
    191 USER_RULE: Ftp      426  22144      *      12    Out      igb0  tcp   
    192 USER_RULE: CloudS  21647  1246K      *      12    Out      em0  tcp   
    193 USER_RULE: CloudS  20840  1198K      *      12    Out      em0  tcp   
    194 USER_RULE: CloudS  20474  1177K      *      12    Out      em0  tcp   
    195 USER_RULE: CloudS  20474  1177K      *      12    Out      em0  tcp   
    196 USER_RULE: BitTor  6939 360060      *      12    Out      igb0  tcp   
    197 USER_RULE: BitTor  6940 360120      *      12    Out      igb0  tcp   
    198 USER_RULE: BitTor  6939 360060      *      12    Out      igb0  tcp   
    199 USER_RULE: BitTor  6939 360060      *      12    Out      igb0  udp   
    200 USER_RULE: BitTor  6939 360060      *      12    Out      igb0  udp   
    201 USER_RULE: BitTor  6939 360060      *      12    Out      igb0  udp



  • Got most other issues resolved.  Anyone else seeing this, or just me?