Installation in VirtualBox

  • Hi everyone,

    I've been trying to get pfSense up and running in a virtual machine before moving to a full machine install.  The install went smoothly, but I can't seem to ping either interface, and I can't access the webConfigurator.  Can anyone help me out?  Here's what I've done so far:

    The machine consists of two network cards - one of which is on the Internet directly (it has an assigned IP address) (em1), and the second is on an internal LAN which already has a router/DHCP server (em0).  The current LAN and DHCP server is

    I've configured both network cards as bridges adapters.  I saw that some people have issues with the AMD adapters, so I chose to emulate the Intel PRO/1000 MT Desktop (82540EM) adapter.

    Both adapters show up in pfSense, and I have configured them as follows:

    WAN (wan) -> em1 -> v4:208.XX.XX.XXX/24    (this is my external IP address which sits on the Internet directly)
    LAN (lan) -> em0 -> v4:      (I've disabled DHCP)

    The (lan) connection is on the same adapter as my host computer, which has no problem accessing the internal network.  I've also tried giving the LAN a 192.168.1.X address to no avail.

    As an aside, I also cannot ping either of these interfaces, and I cannot ping host from pfSense.  I am running 2.1.5-RELEASE-pfSense (i386).

    Thanks in advance for any help you may be able to offer.  Note:  em1 is a complete bridged adapter, Windows does not have IP4/QoS/Client for Microsoft Networks/etc.  em0 is shared with the Windows host, but is also a bridge adapter.


    Edit:  Apologies, I see now there is a specific forum for Virtualization installs.  If a moderator moves my post I understand.  Thanks

  • A bit more information - I found I am able to ping from pfSense (using the WAN connection), so that is good news.  However, DNS does not work.  I am also not able to ping any addresses on the LAN (but this may be correct?).

  • I would highly recommend that you stop right now and grab pfSense 2.2-x64 and start from there.

    I've setup a small lab in Virtualbox many times before and I usually create a 3-NIC vm with em0 simulating a WAN link on my LAN, em1 on intnet1 and em2 on intnet2 to simulate a LAN and DMZ (nevermind em2 if you're not doing a DMZ).  Then I create a small vm (Lubuntu or something) on intnet1 to talk to pfSense WebGUI and do all my testing and playing in the small vm.  Slap a LAMP serve rin the DMZ and play away.  BY default, your WAN is set to block private IP space, so you need to disable that if you want to access it from your real LAN, like testing a port-forwarded server in your DMZ.  Uncheck Interfaces - WAN - Private networks - Block private networks.

Log in to reply