How to block FIN packets?



  • Hi,

    I am facing an issue with "invalid" FIN packets that garbage my audit logs. A short search brought me here:
    https://doc.pfsense.org/index.php/Why_do_my_logs_show_"blocked"_for_traffic_from_a_legitimate_connection

    My solution to this, is no add a block rule before the default "Deny All", that only blocks FIN packets with no-log option on.

    Any idea to how this can be done?

    Thanks!


  • Rebel Alliance Global Moderator

    Are the invalid FIN coming from lan side or wan/internet side?  If coming from lan - shouldn't you look to what is causing the issue vs just not logging ;)

    Even if from the internet maybe look into why??



  • Making the huge assumption that I was creating the rule correctly and that I am remembering from over a year ago correctly.

    I've tried this before, and it seems PFSense only cares about SYN packets for TCP. Since it's stateful, the only time packets need to be checked is when a connection is attempting to be created and the only way to create a TCP connection is with a SYN packet. with my limited understanding, it seems there is no way to block out of state TCP packets with a custom rule. I think I even tried creating my own block-all rule, and it was ignored for out of state packets, but it was a long time ago and I may be creating fake memories based on what I would now think I should test.


  • Rebel Alliance Global Moderator

    I think OP is correct, creating a rule with the flag settings, if you set a rule and set FIN being set and blocked it without logging that should work

    If the packet matched a state then it wouldn't be logged.  If out of state it would be logged by the default rule.  So having rule that looks for traffic with FIN set and not logging it would prevent the default rule from seeing it to log.