Very slow LPR traffic after 2.2 upgrade



  • I have a machine running Ubuntu Server 14.04 with an Epson receipt printer connected to it and set up as a network print server using lprng. Ever since I upgraded pfSense to 2.2 from 2.15 the lpr traffic has been moving very slowly. Print jobs that originate from the network are delayed 1 to 8 minutes. I've originated print jobs from a variety of operating systems and drivers to make sure that wasn't the issue, and it made no difference. What did make a difference was connecting the affected computers to a different router.

    My pfSense router is an Alix 2d13. I've tried connecting the server directly to LAN and another computer directly to OPT1 with the interfaces in a single bridge and fully open, bi-directional firewall rules on both interfaces. I've also connected both computers to a switch connected to the LAN port. I also added a wireless card and connected the devices in various mixtures of wired and wireless as well as entirely wireless on all devices. Print jobs remained slow in all scenarios. I have not yet tried connecting the devices to a switch that is not connected to the router (with statically assigned IP's obviously)  to see if the problem goes away. I'll try that tomorrow and report back. As I said before, though, I did connect the computers to a different router and the issue was instantly resolved.

    All other traffic other than lpr traffic seems to be completely unaffected, so I'm guessing there's some issue with packet prioritization or stateful inspection that's slowing down lpr packets specifically. Any ideas?



  • I'm posting an update to my struggle with this issue with the hopes that someone might be able to help. Since my original post I have installed new hardware with a fresh (non-upgraded) install of 2.2 and with all my settings rebuilt from scratch. The problem remained. So I admitted defeat and reverted back to 2.1.5. This fixed the problem and made it very clear that something in 2.2 was the cause. I may just need to report this as a bug, but I'm going to bounce it off the community one more time just in case there's something I'm overlooking.


Log in to reply